A VirtualDubMod question


Back to topics list
[post:519#5073]
Stretch

06/06/2011 09:42 AM

Reviews: 1918
Posts: 1313

Devil Doll, do you have any recommendations on what to do when MKVExtract breaks an episode up and gives me an AC3 audio segment, with a new icon--and Switch Sound File Converter refuses to recognize such a thing? If I use Switch to open the folder in which I have stored the segments, it shows nothing there. This may be a vast oversimplification, but as I see it, AAC audio is OK, AC3 is no good. I'm guessing that one of these programs may be able to convert from AC3 to AAC, but I don't see such an option within MKVExtract, and if Switch doesn't even recognize AC3 audio segments, what can I do? Has this problem occured to you, and if so, what did you do about it?

Thanks for your help.

[post:519#5075]
Devil Doll

06/06/2011 11:36 AM

Reviews: 365
Posts: 1574

Switch does convert AC3 on my PC. It may not register itself in Windows as being the default application for processing AC3 (and doesn't add a context menu entry "Convert with Switch" for AC3) but if you open an AC3 file with Switch (via context menu "Open with..." in Windows) you can convert the AC3 file to MP3 (or any other format you have a codec available for Switch).

During the conversion, Switch reports "Decoding with ↗DirectX" so it doesn't use an internal component for reading the AC3 stream (which may be the reason for not adding the context menu entry) but uses the one already installed on your PC, the one you use when you play the video file in a video player. So if you can play the video with a player using DirectX (i. e. not VLC who uses internal decoders), Switch should be able to convert the audio stream as well.

When you run Switch and click on "Add File", you'll see a file selection dialog. In the bottom right corner of this dialog you see a drop-down menu for selecting a filter for the visible files, probably showing "Audio Files" as your default setting. When you browse through the available filters you'll in fact not find AC3 as option but you can select "All Files", and then see the AC3 files and open them from inside Switch one by one. But I don't see any option to tell Switch to use this "Add File" file selection filter for "Add Folder" as well.

MKVextract is no format converter, it only extracts streams from a MKV container without modifying their content.

Converting AC3 to AAC would require installing a program able to encode AAC streams, something we didn't need up to this point.

Edited on 06/06/2011 01:26 PM.

[post:519#5076]
Stretch

06/06/2011 04:42 PM

Reviews: 1918
Posts: 1313

OK, it took me awhile to find the drop-down menu, but that wasn't so complicated. I have been using the simplest possible route through the VirtualDubMod process, and had never made any significant changes from your original instructions. I wasn't expecting anything regarding Switch to be located on a display of my own documents, since I saw that as something seperate from Switch. My first MP3 'Convert' is underway as I write this, and I'm sure it will play just fine. Sorry to bother you, and thanks for your help.

[post:519#5077]
Devil Doll

06/06/2011 04:49 PM

Reviews: 365
Posts: 1574

I don't consider this a bother. Feel free to ask any time.

The classical approach for using a computer is: Start an application, then open a file that can be handled by this application. The object oriented approach for using a computer is: Select a file, then choose the operation to be applied onto this file. For me, the latter appears more intuitive - and through the decades, computer handling has developed from the classical to the object oriented approach. Just look at all the touch screen applications these days - what you really want to do is "this thingy, make it so-and-so". Who cares about program names?

Edited on 06/06/2011 04:53 PM.

[post:519#5078]
Stretch

06/06/2011 05:14 PM

Reviews: 1918
Posts: 1313

Actually, I find that after 'Converting' the MP3 file, it has become 'muted'--I get no audio at all. Switch showed a green checkmark to denote a successful conversion, but I can't get it to play. Output format was .wav. I double-checked to make certain that my speakers hadn't been left in mute mode, and they have not. I thought, 'maybe this can't be played until it is recombined with the other video and subtitle segments in VirtualDubMod', so I set that up and ran a test, but still there is no audio. Is there some additional special step which I must take?

Whoops, I meant AC3, not MP3 there. I get confused by computer terminology. I see that you mentioned MP3 above, so I will try to convert the original AC3 audio to that. I see that Switch is warning me that 'Format may not be supported'.

Edited on 06/06/2011 05:44 PM.

[post:519#5079]
Stretch

06/06/2011 05:59 PM

Reviews: 1918
Posts: 1313

What the-- I was going to say that the MP3 conversion was muted as well, but I thought I heard something over the hum of my computer's cooling fan. I turned the speaker volume up to maximum, and found that there is indeed some audio--but it is garbled and I cannot understand it. There were definitely voices and music at one time; maybe they have become 'stretched' and would now be out of sync with the video. It is the same with the .wav conversion. So, both AC3 conversions are at an extremely low volume and have become distorted and useless.

Edited on 06/06/2011 06:02 PM.

[post:519#5081]
Devil Doll

06/06/2011 07:57 PM

Reviews: 365
Posts: 1574

Gnlpf... CAR lost my complete posting by producing an error message...

Switch allows you to "Play" the AC3 stream. Does this work, or is the audio stream already muted there?

When you play the MKV container with Media Player Classic, is the sound still okay? If not, then we're stuck; if this works then we can simulate Media Player Classic for the audio stream much like we're already doing this with the video stream, by adding one parameter to the AviSynth script.

Edited on 06/06/2011 08:00 PM.

[post:519#5083]
Stretch

06/07/2011 11:06 AM

Reviews: 1918
Posts: 1313

When I attempt to play the AC3 stream, Switch begins ‘Decoding Audio Stream’, even though I clicked ‘Play’ rather than ‘Convert’. Again, I get the message ‘Format may not be supported’. Once Decoding is finished, a ‘Play Window’ appears and the audio plays, but again it is garbled and useless. Perhaps we are stuck.

I also lost the first draft of my post here.

[post:519#5084]
Devil Doll

06/07/2011 11:17 AM

Reviews: 365
Posts: 1574

As said in my previous posting, Switch doesn't natively support AC3 but relies on DirectX to hopefully decode the audio stream correctly (regardless whether you "Play" or "Encode" the result), so "Format may not be supported" is correct in so far as Switch doesn't know for sure which audio filters your DirectX installation supports.

Does your Media Player play the audio correctly? If not, then you might need to install a more recent AC3 codec.

When you play the original MKV video, your task bar should show two small icons "FFv" (red, ffdshow filter for video) and "FFa" (blue, ffdshow filter for audio). If you double-click the blue icon you open the configuration dialog for the ffdshow filter which contains the method how AC3 streams are to be interpreted. If even your Media Player Classic doesn't play the sound correctly then you might try to switch between the available alternatives here (on my PC there are two AC3 interpreters, liba52 and libavcodec) and then try again playing with MPC; if one of these options turns out to be working you might get away without installing anything.

Edited on 06/07/2011 11:32 AM.

[post:519#5086]
Stretch

06/07/2011 02:33 PM

Reviews: 1918
Posts: 1313

Media Player Classic seems to play the AC3 audio segment normally, so no trouble there. I must be looking in the wrong place, because I don't see any FFv or FFa icons. We're still talking about MPC, right? Should they be at the bottom right, near the Volume icon?

Again, 'An error occured while attempting to display your post'.

[post:519#5088]
Devil Doll

06/07/2011 04:18 PM

Reviews: 365
Posts: 1574

It looks like MPC is playing the audio on your PC using a different method than Switch and produces different results; this would also explain why you're not seeing the two icons. So for this particular case, let's try bypassing Switch and see what else we can do to get the audio into any usable format.

Recalling the conversion procedure: So far, you're using an AviSynth script (with one line) to get the video stream out of the MKV container. You open this script with VirtualDubMod, then add subtitles and audio from external files, and start the encoding procedure to produce the AVI file. Now let's apply a small modification to this procedure.

In the AviSynth script, I assume you're opening the MKV file with

DirectShowSource ("<filename>.mkv", audio=no)

Let's change this to

DirectShowSource ("<filename>.mkv", audio=yes)

and save the script file to something like "with_audio.avs".

Having done this, open the AviSynth script "with_audio.avs" with Media Player Classic. (You may use the "Send To" mechanism of the Windows Explorer if you already have an MPC entry there, or the "Open with" context menu.)

The result should be that you can both see and hear the anime episode in question, as AviSynth's "DirectShowSource" splits the MKV file into streams and converts them into uncompressed video and audio, which is data that MPC should be able to handle.

Does this work? Do you hear the audio stream this way? (If yes then we can process this audio stream further, otherwise I'd be a bit clueless at this point.)

- - - - -

If this works then you could just make another test. Did you ever play a commercial music CD (!) on your DVD player? Normal DVD players should be able to do this, and if they do then they support uncompressed audio format (i. e. WAV), exactly what we're producing with the modified AviSynth script.
So if your DVD player can play music CDs then you'd be able to bypass the MP3 encoding step and use uncompressed audio instead. (The files will become twice as big but for one-time watching it might be acceptable whereas for archiving the anime MP would certainly be preferable.)

Edited on 06/07/2011 04:32 PM.

[post:519#5090]
Stretch

06/07/2011 06:58 PM

Reviews: 1918
Posts: 1313

I did this, but what I got is not encouraging: The audio is still garbled and at a very low volume--it seems to be stretched out so that it takes far longer than it should, the opposite of the 'chipmunk speak' effect that happens when dialogue is sped up. And now the video seems to only show certain frames, then leap ahead to other ones while ignoring all those inbetween—like a collection of still photos instead of animation. I’m just guessing at the numbers, but it’s like frame one is shown for several seconds, then frame 50 likewise, then frame 100, etc.

[post:519#5091]
Devil Doll

06/07/2011 09:45 PM

Reviews: 365
Posts: 1574

Any buffering issues by using AviSynth would be understandable (depending on the processing power and RAM of your PC) and acceptable (as we wouldn't use the data in real time during the encoding process). But if the audio is still garbled then Switch and AviSynth apparently are using the same interface and suffer from the same issue.

Wikipedia tells me that MPC comes with an internal AC3 interpreter. Could this be the difference? Let's make one more test: Try playing your MKV file with the Windows Media Player (and override any warnings you might get about the file name extension ".mkv"). This way you wouldn't be able to make use of any MPC internal stuff (and by the way, would this now lead to the aforementioned icons showing up in your task bar?). My guess is that the audio will be garbled again, and if so, I'd suggest installing a (more recent) AC3 codec for DirectX.
Your candidate might then be ↗AC3Filter (download page: http://ac3filter.net/wiki/Download_AC3Filter). This filter comes in different download variants, depending on your Windows version. Do you run a 32 bit Windows or a 64 bit Windows on your PC?

But before installing anything, I wonder whether your scenario might be no. 4 of http://www.cccp-project.net/wiki/index.php?title=Issues:Low_Volume. Does that sound like it describes your situation? (Even if you haven't installed CCCP you're using components that are part of this package, such as Haali.)

Ah, I almost forgot this question: Did you ever successfully convert any AC3 audio stream with Switch, or is this the first time you got one in an MKV container?

Edited on 06/08/2011 01:36 PM.

[post:519#5093]
Stretch

06/08/2011 05:52 PM

Reviews: 1918
Posts: 1313

I find that on Windows Media Player there is still low volume and a little skipping about, but not nearly as bad. If it were just a bit better I would be satisfied. I still don't see the FFv and FFa icons. As far as I can remember, I have never successfully converted an AC3 audio stream; they use a different icon from AAC, so I'm pretty sure I would have noticed such a thing, and like I said Switch wouldn't even recognize them until you told me about the 'all files' trick. The CCCP Low Volume entry doesn’t make any mention of the distorted, stretched-out effect, which has been present in every attempt I have made to convert AC3 streams, so I think this is something different. So, perhaps a new AC3 filter is what I need.

[post:519#5095]
Devil Doll

06/08/2011 10:07 PM

Reviews: 365
Posts: 1574

Hm, you could now install the AC3 codec mentioned above. But I don't know whether it will be used via DirectShow then, and I installed my AC3 codec as part of CCCP apparently so our PC configurations are different enough to only trust your eyes and not my imagination. Were you able to activate that blue icon (the DirectX configuration for handling audio) then you could see what your DirectX currently does with AC3 streams, whether you have an alternative on your PC already (without installing anything, on my PC this is the case!) and whether an additional installation actually changed the DirectX configuration. So how do we get that blue icon on your screen?

(lots of complicated ideas deleted)

EDIT: There must be a simpler way. Try this:

  • Play your MKV file with Media Player Classic.
  • Just for safety play: In MPC, select menu "Help" / "About...", and note the "Build Number" (i. e. program version; mine is "1.4.2677.0" from 2010; just to check whether you have a recent MPC).
  • In MPC, select "Play" / "Filters" / "ffdshow Audio Decoder" / "Properties". (That's the "blue icon", explicitly invoked via MPC, and therefore not "blue".) A configuration dialog should open.
  • If you have this dialog, then on the left side of it, select "Tray, dialog & paths". Then, on the right side the first line should be "Icons" with three radio buttons. Which one is selected? (On my PC: "Modern"; this is about the visibility of the icon in the Windows task bar while playing a video.)
  • On the left side, select "Codecs" (first entry). Then, on the right side a table will appear, listing all the codecs that ffdshow is using for audio streams. "AC3" should be one of them. If you find the "AC3" entry and click on the name of its codec in the middle column, this name should change into a select list of available codecs for the AC3 format. Which names do you read in this list? (On my PC this would be "disabled", "liba52" and "libavcodec"; this is where you can try whether you have an alternative without installing anything.)
Note that MPC will most likely not use this AC3 codec - but Switch and Windows Media Player probably will, and we only use MPC to get access to that configuration dialog.

- - - - -

Side note: I upgraded my Switch from 4.02 to 4.14, just in case. Still no native AC3 support there.

Edited on 06/08/2011 10:40 PM.

[post:519#5097]
Stretch

06/09/2011 05:37 PM

Reviews: 1918
Posts: 1313

Looks like my Build Number is 6.4.9.0—Copyright 2002-2006 Gabest. At least five years old! Instead of ‘ffdshow Audio Decoder’ I get ‘MPEG-1 Audio Decoder’. I click on that, and there is no ‘Tray, dialog & paths’, instead there is a display of ‘Properties’, then ‘Settings’. Among these are ‘Output Sample Format’ which is set at ‘PCM 16 Bit’, then ‘AC3 Decoder Settings’ which is set at ‘Decode to Speakers’, DTS Decoder Settings, also set at ‘Decode to Speakers’, and ‘AAC Decoder Settings’, set at ‘Downmix to Stereo’.

I get a funny feeling that maybe the basis of my problems is that I am working with ancient technology here. Whenever I burn a DVD, it is in MPEG4 mode, and here MPEG*1* is in use?

Edited on 06/09/2011 05:39 PM.

[post:519#5098]
Devil Doll

06/09/2011 07:57 PM

Reviews: 365
Posts: 1574

I wanted to see the Audio Input handling (from AC3 to the Media Player), not the Audio Output handling (from the Media Player to the speakers in already uncompressed audio, i. e. ↗PCM). Also note that "↗MPEG-1 Layer 3" is what you know under the name of "MP3".

Perhaps your MPC isn't showing that dialog because it uses an internal AC3 routine. Could you please do the same operation with one of your successfully converted AVI files with an MP3 audio stream inside? The alternative of executing the "blue icon" module with "rundll32" from your Windows "Start" menu / "Run" entry would be a lot more cumbersome for you, and (my) Windows Media Player doesn't have any such dialog.

A MPC from 2006 isn't the latest version but I was hoping it to support at least such a fundamental feature, and I still don't know whether the "blue icon" is invisibly active on your PC (which would be possible due to the "radio button" in the setting) or the function really not invoked. (On my PC I see that blue icon in the Windows Task Bar even when I "play" an AC3 stream with Switch, as "Decoding with DirectX" invokes the ffdshow filter for decompressing AC3, and I would like to be sure it's the same on your PC before modifying your DirectX installation.)

Did you install MPC as separate product, and would you be willing to upgrade this program even though it isn't related to your current problem?

[post:519#5100]
Stretch

06/10/2011 11:48 AM

Reviews: 1918
Posts: 1313

I started playing a successful AVI conversion which has an MP3 audio stream (MPEG-1 Audio layer 3, to be exact) using MPC. Under Play/Filters I get 'ffdshow MPEG4 Video Decoder, but the Audio Decoder remains MPEG-1, same as before.

To be honest, I can't remember if I installed MPC seperately, but I think so. I vaguely remember not being able to get the complex CCCP system to work and choosing MPC instead. If you recommend an upgrade, and can assure me that I am not putting anything crucial at risk, I will gladly do so.

I am sorry that this is taking so much time and effort. If only your first post had fixed everything!

P.S: I swear, trying to make a post here always fails on the first try!

Edited on 06/10/2011 11:49 AM.

[post:519#5102]
Devil Doll

06/10/2011 10:46 PM

Reviews: 365
Posts: 1574

My main problem is that I can't see what's happening on your PC, and the more negative tests we do the more questions I have.

I told you that when I "play" the AC3 in Switch I get the message: "Decoding with DirectX". You posted that when you do the same you get "Decoding Audio Stream". Is that the exact wording of the message, or does your message explicitly mention DirectX as well? We're trying to find out which system component is interpreting your AC3 stream so this is important.

If you install a more recent MPC this shouldn't have any effect on your operating system, and even if your MPC installation ends up being broken somehow you would still have Windows Media Player as backup, so this should be not that risky as compared to installing Haali or something like that. (On my machine MPC is part of CCCP and I only began using MPC when my previous ZoomPlayer ceased to have certain features so I haven't performed a separate MPC installation myself so far.)

I believe to remember that your CCCP problems resulted from having another codec pack (K-Lite) installed already, and these two don't go well together as they share quite a few components.

Edited on 06/11/2011 12:32 PM.

[post:519#5103]
Stretch

06/11/2011 12:55 PM

Reviews: 1918
Posts: 1313

"Decoding Audio Stream" was the exact wording here; there is no mention of DirectX.

So, perhaps I should upgrade my MPC to 1.4.2677.0? Should I install the AC3Filter as well?

[post:519#5105]
Devil Doll

06/11/2011 04:18 PM

Reviews: 365
Posts: 1574

If your Switch doesn't use DirectX for decoding AC3 then installing an AC3 filter for DirectX would not solve your problem. That's the very reason for finding out who is decoding your AC3 stream - to avoid an installation that wouldn't make any difference in your current case:

  • If Switch were responsible for decoding AC3 (which is not the case as Switch doesn't natively support AC3) then upgrading Switch would be the remedy.
  • If DirectX were responsible for decoding AC3 (which is the case on my PC) then upgrading the AC3 component of DirectX (i. e. installing a new AC3 filter for DirectX) would be the remedy.
But we still don't know who decodes AC3 on your PC when you try converting an AC3 stream via Switch or play an AC3 stream via Windows Media Player.

The same goes for MPC: It probably wouldn't hurt to get a more recent version but as your old MPC already handles the AC3 stream correctly while Switch does not, Switch (and as such the whole conversion procedure) wouldn't profit from getting a new MPC.
The only feature a more recent MPC might give you is an easier access to the ffdshow configuration for audio filters (in order to check whether the icon's visibility is set to "hidden" on your PC by this configuration), the one that on my PC handles AC3 when being played by Switch, Windows Media Player and MPC, proven by showing the blue "FFa" icon in the Windows task bar on my PC. If that's different on your PC and we don't know who handles your AC3 streams I can't give you a reasonable suggestion what to install.

For clarity's sake: Wikipedia page ↗ffdshow has an image on the top right side. If you click on this image you get here. This is almost the configuration dialog I've been talking about. In the top bar you read "ffdshow video decoder configuration", and you can see a reddish-brown icon "FFv" on the left top corner. Its twin dialog "ffdshow audio decoder configuration" has a blue "FFa" icon () instead of a reddish "FFv" one. Unfortunately, the color of these icons is configurable within their own configuration (you see "Tray, dialog & paths" on the left side of this image as I described above), and even the display of these icons can be disabled by the same configuration.
As long as I haven't seen your ffdshow configuration I can't tell whether you don't see the icon because its display is disabled or because ffdshow isn't used for decoding AC3. But that's exactly what we need to know before installing anything.

So, as all else has failed, could you please try this: http://forum.videohelp.com/threads/300132-Open-ffdshow-config-screen-without-opening-a-movie (best of luck for finding the path name). If you get that working you might want to manually create a new desktop icon with this command.

Does your K-lite installation have anything like a configuration dialog that would define who is responsible for interpreting AC3 on your PC? CCCP is running on my PC, and as you have experienced how CCCP and K-lite won't like each other I can't simply install K-lite on my PC to see how that works.

Different approach: You might want to try a separate tool for converting AC3 to MP3, such as http://www.videohelp.com/tools/AC3Tool. I haven't tried this though, and I don't know whether it works stand-alone or relies on anything on your PC.

Edited on 06/12/2011 09:47 AM.

[post:519#5107]
Stretch

06/12/2011 01:10 PM

Reviews: 1918
Posts: 1313

I was afraid that being the relatively computer-ignorant person that I am, I might have missed the FFv icon even though it was in a fairly obvious place, but having seen it on Wikipedia I can say with confidence that I've never seen that before. Could my AC3 Filter possibly have anything to do with this problem? If not, I suppose I will give AC3Tool a try.

[post:519#5109]
Devil Doll

06/12/2011 01:50 PM

Reviews: 365
Posts: 1574

To answer your question I would have to know which AC3 decoder is used in your PC... if it were invoked via DirectX then it would be a "filter" but there are other mechanisms a codec (= "coder / decoder") can be invoked by. That's the problem with "installing a codec" - you have to understand the type of codec in order to understand who will be able to make use of it, and where you'd have to configure this.

The place where this icon should appear is the place where all "iconified" programs have their icon in your Windows task bar. Unfortunately, most programs that I know you're using don't have such an icon, and the programs that have such an icon on my PC right now are all such that you're probably not using (Windows Task Manager, VLC, virus scanner, file manager, Internet connection).
And actually, you have seen this icon already. At least you said so in this forum posting. Are you able to repeat what you did back then?

You could still do the two things I suggested in my previous posting, i. e. try to open the ffdshow configuration as described in that "videohelp" forum posting, and trying to scan your program menus for some kind of K-lite configuration tool that might contain the setting about who is decoding your AC3 streams. Both of this would be following the idea to find the root of the problem, and solve it with either a configuration change or an installation. You could also try to bypass the problem be not using Switch for AC3, and instead give AC3Tool a try. It's your choice.

Edited on 06/12/2011 08:59 PM.

[post:519#5111]
Stretch

06/13/2011 10:50 AM

Reviews: 1918
Posts: 1313

The reason I made my first post on this topic was that I had downloaded a fansub, ‘VOTOMS: Alone Again’ and couldn’t get the audio to work. After you pointed out that I had seen the ffdshow icon in the past, I started playing an MKV fansub, chosen at random (‘Hoshizora’ ep. 8), and examined the Task Bar. Sure Enough, there was the ‘ffdshow audio decoder’ icon. I examined this episode under MediaInfo and found that it had A_AAC as its audio codec. I tried again with VOTOMS, and it definitely does not display the ffdshow icon; it, of course, has AC3 as its audio codec.

I don’t exactly understand what Furuya and Guns1inger are talking about; is this some sort of reprogramming of the computer as a whole?

Try this from start->run

for DirectShow rundll32.exe ffdshow.ax,configure
for Audio rundll32.exe ffdshow.ax,configureAudio
for VFW rundll32.exe ff_vfw.dll,configureVFW


Ah, this forum keeps locking up in 'Loading, please wait' mode. If I can get past that, an error occurs and my post is lost. Luckily, I have learned to type my post elsewhere and have a backup copy.

[post:519#5113]
Devil Doll

06/13/2011 01:41 PM

Reviews: 365
Posts: 1574

You found the blue icon! (Furuya and Gunsl1nger discussed a method to get that icon without requiring to play a video.)

If you play Hoshizora, you can double-click that blue icon. The ffdshow audio configuration dialog will appear.

In this dialog, select "Codecs" (left side, top entry). A table with three columns will appear on the right side.

  • In this table, do you find an entry named "AC3"?
  • If so, which "decoder" (middle column) is in use?
  • When you click on this "decoder" name, it should turn into a drop-down list. Which entries are available in this list?
For your motivation: The above is where you tell ffdshow whether to use the AC3 filter we might possibly install as the next step (but only if we need to do so, perhaps we just need to change that configuration setting).

Edited on 06/13/2011 02:35 PM.

[post:519#5115]
Stretch

06/13/2011 06:58 PM

Reviews: 1918
Posts: 1313

Hey, I did something right! There is an AC3 entry, but its decoder is 'disabled' (there is nothing under 'details'). The only 'formats' which are not 'disabled' are AAC, AMR, True Audio, and AVIS (Avisynth). The drop-down list for AC3 lists 'Disabled' (again), 'liba52', and S/PDIF. Does this tell you anything?

[post:519#5116]
Devil Doll

06/13/2011 08:10 PM

Reviews: 365
Posts: 1574

On my PC, "liba52" is doing the AC3 decoding. (I also have ↗libavcodec as available alternative and I'm a bit surprised you don't get this as choice, but maybe liba52 will already do the trick for you.)

As the "MP3" entry is disabled on your PC as well, this explains why you didn't get the blue icon when playing an AVI container. Apparently your K-lite installation only makes minimal use of ffdshow and handles a lot of stuff by its own routines. (On my PC with CCCP installed, ffdshow is being used for 17 audio codecs.)

So you might try setting the AC3 entry in ffdshow to "liba52", confirm the change with the "Apply" button, and then try the following:

  • Play "VOTOMS: Alone Again" with Windows Media Player. Is the sound different now? Does the blue icon appear in the task bar?
  • Play "VOTOMS: Alone Again" with Media Player Classic. Is the sound still okay? Does the blue icon appear in the task bar?
  • Play the extracted AC3 stream with Switch. Is the sound different now? Do you get "Decoding with DirectX" as message? Does the blue icon appear in the task bar?
If the results are insufficient for your purpose, you may try the same with S/PDIF.

When doing your experiments and the blue icon appears, double-click it and select "Volume" (not the checkbox, instead click on the word "Volume" on the left side). A dialog should appear. Check "Show current volume levels". Is the loudness of the audio okay? If it is unusually low, check "Normalize". Does it get better? This isn't a perfect solution for permanent use but you might amplify the loudness of a particular audio stream through this dialog if necessary.

And if none of the above suits you, the next alternative would be to install AC3filter. Or try looking for a configuration tool within your installed K-lite pack, and check whether K-lite has alternative AC3 codecs available.

Edited on 06/13/2011 08:47 PM.

[post:519#5118]
Stretch

06/14/2011 07:20 PM

Reviews: 1918
Posts: 1313

I ‘applied’ liba52 but find that nothing has changed. Both in WMP and MPC the sound is still messed-up and at very low volume, and there is no blue icon. I double-checked to make sure MPC hadn’t gone back to ‘disabled’ mode somehow, but it hasn’t and liba52 was still the codec of choice. When I click ‘Play’ with Switch, it went into ‘hourglass/please wait’ mode for several minutes then attempted ‘Decoding Audio File’. When it is finally ready it is as terrible as before—much worse than the audio I got when I played the episodes on WMP and MPC. I changed to S/PDIF but the results are the same with both WMP and MPC. I went looking in ‘All Programs/K-lite Codec Pack/Configuration’ and found ‘ffdshow’, ‘AC3Filter’, ‘Codec Tweak Tool’, ‘DirectVobSub’, ‘Divx Decoder’, ‘Haali Media Splitter’, and ‘Xvid Encoder’. There is also a ‘Tools’ section, but none of the names there are familiar.

[post:519#5119]
Devil Doll

06/14/2011 08:45 PM

Reviews: 365
Posts: 1574

If enabling "liba52" for processing AC3 within ffdshow doesn't make the blue icon appear then somewhere on your PC someone else is processing AC3 with higher priority than ffdshow, i. e. ffdshow isn't even asked to do this.
This also means that as long as you can't get your PC to use liba52 (a ffdshow filter) for handling AC3, installing another ffdshow filter for AC3 would probably have the same effect, i. e. none.

My guess is that this must then be your K-lite codec pack. So the configuration section of K-lite would indeed be the place to look for a setting that enables AC3 processing there, and if you find that configuration part of K-lite you might be able to do similar experiments to the one you did right now. Apparently K-lite uses an AC3 codec that can't handle your VOTOMS audio stream, and if you disable that K-lite component then ffdshow might be asked to handle AC3 instead. Given that AAC (!) is processed by ffdshow, i. e. you get the blue icon when playing Hoshizora, it means that ffdshow isn't completely disabled on your PC, and the logical conclusion would be that whoever within K-lite claimed being responsible for processing AC3 prevents ffdshow from handling this task, so if you disable AC3 processing in K-lite then ffdshow should fill in.

Of the K-lite sections you named, the first three sound promising: "ffdshow" might actually be the same you used in the previous step but there's a chance that you have several ffdshow installations on your PC and the one you tweaked for liba52 wasn't even the "active" one for AC3 handling. If you open this configuration part, does it look like the one you've already seen, and is liba52 set to handle AC3 there?
"AC3Filter" might also be a candidate, even more as this was the codec we considered installing earlier in this thread - so you have that installed already. But is it active? Can you see that from the K-lite configuration? If it is active then AC3Filter might even be the root of the whole problem, and disabling it might allow ffdshow to take over and handle the task. And if it is not active, you can try setting it to active and do the WMP and Switch tests once again. (The MPC tests are only to make sure you didn't make anything worse than before, as MPC is your player of choice and if anything gets worse there you should undo that previous change with highest priority. Didn't you write that MPC played VOTOMS correctly before you changed anything within ffdshow? Try undoing this change, and check again how MPC plays that episode. WMP is relying a lot on Windows components instead of shipping its own set of codecs, and thus is my primary candidate for testing whether any configuration change actually had an effect, even more so because I don't normally use it for playing videos.)
And finally, "Codec Tweak Tool" might be a way of fine-tuning the processing of streams by codecs, which might include handling AC3. It doesn't hurt to give it a look but if it looks like rocket science then rather not change anything there.

It's a pity that you use K-lite and I use CCCP, so I can't guide you through these K-lite configurations. If you're feeling you're not getting anywhere on this path, there's always plan B: Install AC3tool as alternative to Switch for converting AC3 streams. This won't fix the behavior of Windows Media Player though.

Edited on 06/14/2011 08:53 PM.

[post:519#5121]
Stretch

06/15/2011 02:11 PM

Reviews: 1918
Posts: 1313

K-lite Codec Pack/Configuration/ffdshow seems to be the same as before; S/PDIF is the codec of choice, just as when I last left. When I click on K-lite Codec Pack/Configuration/AC3Filter I get a stern warning:

“WARNING: This utility is for OFFLINE filter configuration only! This means that you will not see any activity of currently playing applications and configuration settings will not affect them. You’ll need to restart your player for changes take in effect”

After I click ‘OK’ I am taken to the AC3Filter ver. 1.11 control panel. I wonder why I got such an ominous warning when the first time I reached what appeared to be this same place via a route outside of K-lite I got no warning at all. Maybe the warning will mean something to you.

I went to Codec Tweak Tool and found an interesting option box: ‘Boost AC3 volume’. Another box would allow me to not use AC3Filter for PCM or MPEG volume. I can also ‘reset (AC3Filter) to recommended settings’. I can also ‘disable the following filters’, one of those filters being AC3Filter. At first it looks like none of these options has been check-marked, but when I click on ‘Settings’ (because it seems to be a flow-chart prerequisite to Boosting AC3 volume), checkmarks immediately appear at both ‘Boost AC3 volume’ and ‘Don’t use AC3Filter for PCM or MPEG volume’, plus another option, ‘Hide system tray icon’. So, I will wait and see what you have to say about this.

[post:519#5123]
Devil Doll

06/15/2011 03:38 PM

Reviews: 365
Posts: 1574

So apparently you have only one ffdshow installation; that's good. Still, it isn't used for decoding AC3 so far.
Nevertheless, change the ffdshow audio setting for AC3 to "liba52", as disabling AC3Filter (see below) might then result in liba52 decoding the AC3 streams on your PC (which would be the same as in my configuration).

The "WARNING" apparently just says "Don't expect that setting change to have an effect for the video you're already playing, you need to restart WMP resp. MPC for that" (which is much better than having to reboot the PC, for example). And I wouldn't expect any immediate change anyway because this would have been unnecessarily difficult to implement (changing the codec while playing a video is like changing a horse in the middle of the race).

Remember the link to that CCCP page where they discussed the low-volume AC3 streams for "high quality" devices? Perhaps "Boost AC3 volume" is the setting to get these "silent" audio tracks to a loudness more suitable for PCs. But as you mentioned the audio sounds garbled, boosting the volume alone may not be what you want; of course it doesn't hurt to try this "boost" and then play VOTOMS with WMP to check whether it had any effect. (I showed you the "boost" equivalent within ffdshow audio configuration already but as long as ffdshow isn't allowed to decode AC3 this won't help you.)

Try disabling AC3Filter in K-lite (completely, not just for PCM or MPEG). Does that change anything when you play VOTOMS with Windows Media Player resp. the AC3 with Switch? Does the sound change, and does the blue icon appear in the system tray?
Our goal here is to see whether AC3Filter is the culprit. If no then we have to continue searching; if yes then we can either keep it disabled (and hopefully get better results from ffdshow) or try fiddling with the AC3Filter settings (which I'd prefer to avoid as I could only give you a link to the user manual).
If you do get the blue icon now, you may alternatively try "S/PDIF" for AC3 in the ffdshow audio setting, and decide whether S/PDIF or liba52 produces the better results for you. As the "WARNING" told you, restart WMP for every test or else you won't see the effect of the configuration change.

As for the "system tray icon", that's apparently for K-lite what the "blue icon" is for ffdshow audio, the reddish/brown icon for ffdshow video, or the white icon for the Haali splitter. There might be some people who consider these icons unnecessary as they don't care which system component is handling their video/audio streams; but you, receiving media files from various sources with ever changing file formats, and occasionally needing to install new software because of this, should keep these system tray icons active whenever possible, if only to be able to give a maximum of diagnostic data when necessary, and also to become familiar with these components by seeing these icons whenever you play media files of certain stream types. Plus it gives you a shortcut to the configuration dialog of the software you're using at this moment without you having to know that software's name and find the corresponding entry in your program manager menu tree.

Edited on 06/15/2011 03:41 PM.

[post:519#5125]
Stretch

06/16/2011 06:29 PM

Reviews: 1918
Posts: 1313

I have changed the AC3 codec setting back to liba52 from S/PDIF. When I disable AC3Filter the blue ffdshow icon is displayed in WMP, but the audio is still not quite acceptable. With Switch, however, I notice a change: as always, it attempts ‘decoding audio file’ but whereas previously the end result was much worse than what I got when I simply played the fansub with WMP or MPC, now the end results seems to be OK, except for one thing: all voices seem to have disappeared and only BGM and sound effects remain! Volume is still very low.

I switched to S/PDIF to see if it would be any better, and found that when played that way, VOTOMS Became completely muted and two ffdshow icons were visible! Maybe this is due to making the change. I get a message from RUNDLL that ‘an exception occurred while trying to run “ac3filter.ax,config”’. That’s odd, because RUNDLL is a program that doesn’t seem to do anything and which I consider a nuisance and would uninstall if I could find it in ‘all programs’. Why would RUNDLL get involved? For some reason, with both WMP and MPC subtitles do not begin to appear until the anime is well underway (30 seconds or so), even though a narrator is talking right from the start.

I hope I have reported everything accurately here; it gets confusing.

Edited on 06/16/2011 06:37 PM.

[post:519#5127]
Devil Doll

06/16/2011 11:53 PM

Reviews: 365
Posts: 1574

You're doing a good job in reporting.

First, some encouragement: So disabling AC3Filter did allow ffdshow to take over the AC3 handling, which is what I was trying to get working. You now have three options for handling AC3: Using AC3Filter (via K-lite), using liba52 (via ffdshow), or using S/PDIF (via ffdshow). And you know how to enable each of these. Each option may allow fine-tuning in their respective configuration areas. Which one turns out to be the best one for you remains to be seen as I can't compare "still not acceptable" to the previous results.
On my PC I have a fourth option for handling AC3: Using "↗libavcodec" (via ffdshow, it then appears as alternative to "liba52" within the "blue icon" config dialog for AC3). According to Wikipedia it should be part of any normal ffdshow installation. libavcodec is a pack of many, many ffdshow filters (video as well as audio, including H.264/AVC, we discussed that in the "mencoder" thread), and to use it you would probably need to have a file "libavcodec.dll" in the same directory where "liba52.dll" already resides on your PC. Are you able to search for these two files?

Some guesswork about the test with the voices missing: Try this again, preferably playing a scene with both music and dialogs, then double-click the blue icon. On the left side, select the word "Volume". A dialog should appear on the right side that looks like a stereo equalizer. Check "Show current volume levels". Some of the channels should now be moving bars showing the loudness of each channel. How many 'active' channels do you see?
My guess is the following: Your AC3 material is using more than two channels, perhaps some 5.1 format. (MediaInfo? I just learned during our experiments that Mediainfo is built-in for my MPC from 2010, so no external program call required any more, just "File" / "Properties" / "MediaInfo".) But your MP3 file as conversion result will have only two channels, left and right. So the problem may be that Switch lets the AC3 stream be decoded and then selects two channels as "left" and "right" one, ignoring the other channels, some of which just happen to contain the seiyuu voices...
I don't really know whether we can make Switch behave differently. Apparently Switch isn't flexible enough to give you a choice as how to map 5 channels from the AC3 input to 2 channels in the MP3 output; I looked up all "Options" dialogs in Switch and found none suitable for your needs. This may be the point to give up on using Switch for AC3.
By the way, your ffdshow configuration does allow you to do such a mapping: Try playing Votoms with WMP, double-click the blue icon, then select "Mixer" on the left side. A dialog should open where you could map each input channel to an output channel of your choice. How are the (probably five) channels mapped for this audio stream? But I'm not sure whether we can get Switch to make use of this mapping.

And here's the bad news for today: I just tried to install AC3Tool (which hopefully may have a more flexible user interface for this purpose) but the installation program wasn't able to overwrite some system file in my Windows directory. I skipped this file, then read the README file which told me to install Visual Basic 6 runtime enviroment as prerequisite. I did that, but AC3Tool still isn't able to find some file and doesn't even start on my PC. I'm not sure whether I should recommend to you trying the same thing.

Hm... what options do we still have? Let's see. You still have the avicodec script for playing the video with audio, the one that caused delay and "stills" for the video? With "liba52" being your AC3 codec, try again playing this script through Windows Media Player. How is the audio now? (Don't care for the video here.)

I don't know the exact state of your PC but both the two blue icons and the error message are probably symptoms of the same issue: Two instances may have tried to handle an AC3 audio stream at the same time. Did you have several Media Player instances running simultaneously, or WMP and Switch at the same time? Just one test at a time, please, and always quit the program before starting the next experiment as the running video player keeps its codecs loaded in the system. I just tried running WMP and MPC simultaneously and in fact got two "blue icons" then.
As for the message text: Codecs, filters etc. are not "programs" (*.exe), they are "modules", i. e. executable parts of some kind of program library. To execute them, there has to be a Windows system component capable of reading those program library files and extract & start one module from there - this is "rundll" ("run a module from a ↗DLL"). So that's what happens every time when you play a video and for many other tasks within Windows even though you never notice this; it's apparently just the collision between the two "blue icons" that cause this error message. But the exact message says that someone tried to run the module "config" from the library "ac3filter.ax", i. e. the AC3 (configuration) routine from K-lite that you hoped to have disabled. Please check that setting again.

Edited on 06/17/2011 01:12 AM.

[post:519#5128]
Stretch

06/18/2011 09:20 AM

Reviews: 1918
Posts: 1313

I ran a search for ‘libavcodec.dll’ in ‘All Files and Folders’, and was told that it could be found in C:Program FilesK-Lite Codec Packffdshow. I also searched for ‘liba52.dll’ and got the same result. I followed that route, and sure enough, found both programs, plus 15 others that all bore the same icon, namely a sheet of paper with two gears on it.

I started playing the original AC3 stream, the one which Switch doesn’t recognize, using MPC. I chose this one since the one which had gone through the Switch ‘decoding audio file’ step presumably wouldn’t have any voices. I set my speaker volume at around 50% (average) so that comparisons between different playings won’t be skewed. I find that clicking on ‘Volume’ within ffdshow causes volume to jump considerably. That makes it too loud. I click ‘Show Current Volume Levels’, and see all six channels, L, C, R, SL, SR and LFE seem to be active, though not all at once. But I doubt that this is what you need to know. I figure that what I need to do next is see what happens when the ‘decoded’ one (no voices) stream is played. Except I can’t find it again. Maybe since the order was simply to ‘play’ it, the decoded version hadn’t been saved anywhere. I attempted to repeat the process of asking Switch to Play VOTOMS, and as before it goes into ‘decoding audio file’ mode, but in the end the new stream is one of the terribly garbled and painful to listen to ones. Some setting must have been changed somewhere, since I didn’t get the same result. But AC3Filter is still disabled in Tweak Tool, so I'm trying to figure out what has gone wrong.

By chance, I notice an option to examine the original, unrecognized-by-Switch AC3 file using MediaInfo, and I see ‘Channel positions : Front: L C R, Rear: L R, Subwoofer’.

It might be a good idea to give a more precise description of what I meant by "still not acceptable" quality of some streams. They sound perfectly acceptable at first—volume is normal, and both voices and music are clear and undistorted. The problem seems to be that instead of flowing smoothly, every so often—once or twice a second, perhaps—the flow is broken up by the stream going mute for a fraction of a second. This is annoying and if I had no other option I would be tempted to watch the show completely muted rather than like this.

Basically, I have been busy and am still trying to carry out your instructions from the last post. I’ll get back to you when I have.

Edited on 06/18/2011 09:25 AM.

[post:519#5129]
Stretch

06/18/2011 10:06 AM

Reviews: 1918
Posts: 1313

When I ask WMP to play V_Alone_with_audio.avs, I get a warning that ‘The selected file has an extension (.avs) that is not recognized by Windows Media Player, but the player may still be able to play it’. I tell it to do so, and find that the audio seems perfectly normal! Volume may be a little low, but I think just turning up the volume on a TV set would fix this. I also notice that there are now two Haali Media Splitter icons on the task bar. I also notice that the video seems to be showing something like every other frame, which is imperfect but much better than the ‘still photo mode’ that happened earlier.

[post:519#5131]
Devil Doll

06/18/2011 05:43 PM

Reviews: 365
Posts: 1574

As you do have "libavcodec.dll" in the correct place I'm a bit surprised that you don't get it as option for decoding AC3 via ffdshow. But maybe your file version is ancient? When I select the file "libavcodec.dll" in Windows Explorer, it is "3,02 MB" large with "last modification date: 09.10.2010".
As you've been working with ↗K-lite for quite a while now I won't tell you to use anything else, but the latest release of this pack is a mere 13 days old, and if you feel like updating K-lite it might upgrade a lot of multimedia elements of your PC to the latest version in one step.

Yes, six channels being active is exactly what I meant with "↗5.1 audio stream", and would explain why Switch only selects the "R" and "L" channel and ignores the other four, resulting in no seiyuu.

Switch's "Play" doesn't create a file (if you wanted that file you'd have to "convert" the input to WAV; I used "Play" only to make sure that Switch's MP3 compressor isn't part of the problem), it merely sends the audio data to your speakers.

You're playing AC3 streams via a codec now that is a ffdshow filter. So if the volume would still need some boost then try this:

  • Play "V_Alone_with_audio.avs" with WMP. The blue "ffdshow audio" icon should appear.
  • Double-click that blue icon. On the left side, select the word "Volume". The channels dialog should appear.
  • In this dialog, check the check boxes for "Show volume current levels" and "Normalize".
  • Below the "Normalize" line there's an input field that limits the "max. amplification" in percent; on my PC the default setting is "400". Keep it as it is. But when you have activated "Normalize", then next to this field on the right side there should be (barely visible) the word "Current" with a numeric value (that might change often but become stable after a while). This is the boost factor that "Normalize" has selected for this audio stream; if it is larger than "100" then your audio stream should have become louder. Which value do you get for "V_Alone_with_audio.avs"?
  • If "Normalize" makes your audio too loud, then use a value below "400" for "max. amplification".
  • Additionally, you may want to try select "Regain Volume". When you move the mouse over this option, a tool-tip should appear and explain what this would do ("night mode").
To make any of the above permanent, confirm the change with "Apply".

Regardless whether the above further improved your situation: If the audio from the AviSynth script seems acceptable then let's try working with it. How would we do that?
  • Open "V_Alone_with_audio.avs" with VirtualDubMod.
  • Do what you always do for conversion: Add the subtitles, select "XviD" for video compression. Just do not import an audio stream - the AviSynth script already contains one as you have seen.
  • Start the compression. The resulting file will become bigger than usual (about 500-600 MB) because the audio stream is uncompressed; your DVD player should be able to play it anyway, we're doing the MP3 compression mainly to keep the files reasonably small.
  • Play the created AVI file with MPC; does it work?
  • If yes: Burn the result on a disk and try it on your DVD player; does it work?
If this turns out to be successful then the next step would be to compress this audio stream to MP3.

Edited on 06/18/2011 07:52 PM.

[post:519#5133]
Stretch

06/19/2011 07:34 PM

Reviews: 1918
Posts: 1313

Actually, volume seems to be satisfactory when I play V_Alone_with_audio.avs, using WMP and with AC3Filter still disabled, so I’d rather not fool with it. Video, however, has gone back to ‘still photo’ mode, that is only showing every tenth (or is it hundredth) frame instead of around half of them. Maybe this is because my PC is doing something else which requires a good deal of memory.

I have carried out the attempt to convert V_Alone_with_audio.avs, using VirtualDubMod, and so far the results seem perfectly normal and satisfactory! Whereas most fansubs are in the six-digit KB region, this one has a size of 2,034,438 KB. When I ‘Send’ it to My Documents the initial estimate is that the process will take something like 18 minutes, although in the end it only takes one or two. I will burn it onto a DVD and let you know how playing it elsewhere went.

I’m not sure what you mean by “If this turns out to be successful then the next step would be to compress this audio stream to MP3”. What I’m talking about is a complete episode, with both audio and video. Since I never separated the audio stream, and instead let Avisynth handle it, which audio stream are we talking about?

So, was it disabling AC3Filter which allowed us to get this far?

Edited on 06/19/2011 07:36 PM.

[post:519#5135]
Devil Doll

06/20/2011 06:23 PM

Reviews: 365
Posts: 1574

My guess is that yes, disabling AC3Filter made the difference, visible by letting the blue icon appear and the audio quality improve, now that ffdshow/liba52 is doing the job. You're free to enable AC3Filter again in K-lite and check the quality of the audio in the AviSynth script, now that you know how to do that.

The "still photo" mode is the result of your PC not being indefinitely fast. AviSynth creates an uncompressed video stream of an immense size (easily 100.000.000 KB and beyond), and in order to allow you to move back and forth within the stream it has to buffer video & audio data in your main memory (so you now know who's using all these resources), therefore displaying these frames during the transformation process can't be done in real-time by your PC. ("Playing" the AviSynth script isn't the way these data are normally meant to be used, we only do that to show you what we get at this point in the processing chain before VirtualDubMod begins to transform these data by resizing, adding subtitles, and compressing via XviD.) So the fact that AviSynth offers a buffered video stream for display purposes with some delay effects shouldn't bother you because speed doesn't really matter during the compression process; the compression result will be playable much faster.

The file size of 2000 MB looks surprisingly large, and I have a bad feeling because of this. A MP3 stream (128 kb/s) for one episode, i. e. 24 min of playing time, takes about 25 MB file size; an uncompressed audio stream (1440 kb/s) should require 11,25 times as much space, i. e. 280 MB. Now add the 150-200 MB of the XviD-compressed video, that's where my estimate of 400-500 MB came from. You did all the necessary steps for compressing the video, i. e. resize to below 720px width and compress with XviD? (MediaInfo will tell you.)
If the file size is indeed 2000 MB then the uncompressed audio stream may still contain 5.1 channels instead of 2.0 stereo; this may cause two problems:

  • Your DVD player may or may not be able to play 5.1 audio in WAV format, that's why you have to test this.
  • The next step would have been to extract this audio stream (VirtualDubMod can do that) and run it through Switch for compressing to MP3, and then re-import the MP3 stream to the encoding process as usual. But if this audio is still 5.1 then Switch may still have the same problems handling this uncompressed audio stream that it had when compressing the AC3 stream, i. e. selecting just 2 channels and ignoring the seiyuu voices. My intention was to let ffdshow handle this 5.1 to 2.0 "downmix" conversion in order to make the MP3 compression task easier for Switch but perhaps the "Mixer" settings only apply to your PC speaker output, not to the audio stream processing. (You see, my experience with 5.1 audio streams is about the same as yours...)
So the next steps for you would be:
  • Try playing the DVD;
  • post MediaInfo data here for both the video and audio stream of the created AVI file.
Another idea: Normal MP3 can't contain 5.1 channels but its successor format ↗MP3 surround can. You would need some MP3 surround encoder in order to create this but I haven't tried how to use this, and apparently Switch can't use it as plugin. Apparently MP3 decoders should be able to handle this new "MP3D" format but a test on your DVD player would certainly be necessary.

Edited on 06/20/2011 06:37 PM.

[post:519#5136]
Stretch

06/21/2011 12:15 AM

Reviews: 1918
Posts: 1313

Unfortunately, when I tried to play the new DVD on a DVD Player, I got the message "This format cannot be played". I tried it on a second player and this time it just froze up with the timer at '0000'. I'm sure I performed both the Resize and Compression steps. Here's what MediaInfo has to say about the V_Alone_with_audio.avs (now avi) episode:

General #0
Complete name: C:Documents and SettingsOwnerMy DocumentsV_Alone_with_audio.avi
Format : AVI
Format/Info : Audio Video Interleave
Format/Family : RIFF
File size : 1.94 GiB
PlayTime : 49mn 28s
Bit rate : 5608 Kbps
Writing library : VirtualDub build 32839/release


Video #0 Codec : XviD
Codec/Family : MPEG-4
Codec/Info : XviD project
Codec settings/Packe : Yes
Codec settings/BVOP : Yes
Codec settings/QPel : No
Codec settings/GMC : 0
Codec settings/Matri : Default
PlayTime : 49mn 28s
Bit rate : 987 Kbps
Width : 704 pixels
Height : 396 pixels
Aspect ratio : 16/9
Frame rate : 23.979 fps
Resolution : 8 bits
Chroma : 4:2:0
Interlacement : Progressive
Bits/(Pixel*Frame) : 0.148
Writing library : XviD 1.2.-127 (dev)


Audio #0
Codec : PCM
Codec/Family : PCM
Codec/Info : Microsoft PCM
PlayTime : 49mn 28s
Bit rate : 4608 Kbps
Channel(s) : 6 channels
Sampling rate : 48 KHz
Resolution : 16 bits
Video0 delay : 5s 523ms

[post:519#5137]
Devil Doll

06/21/2011 12:33 AM

Reviews: 365
Posts: 1574

Just as I thought: The video is okay, the audio is still 5.1 channels and thus three times as large as I hoped for, and probably unplayable on your SAP because of this.

When you play V_Alone_with_audio.avs with WMP, and open the "blue icon" and select "Mixer" on the left side, how are these six channels mapped, i. e. how many lines do contain at least one "1" in this table? Apparently we need to find a way to "downmix" this 5.1 channel audio stream to 2.0 before you'll get it playable on your DVD player (i. e. convertible by Switch).

Edited on 06/21/2011 01:00 PM.

[post:519#5139]
Stretch

06/21/2011 02:24 PM

Reviews: 1918
Posts: 1313

When I double-click the ffdshow icon while playing the show, I am automatically taken to 'ffdshow video Decoder Configuration'. I don't see any option to change to audio mode. By going through All Programs/K-Lite/Configuration/ffdshow I am able to reach 'ffdshow Audio Decoder Configuration'. But when I select 'mixer ouput' (there doesn't seem to be a plain 'mixer' option anywhere), and 'apply' the change, nothing seems to happen--just 'apply' is lowlighted and no longer an option. Somehow I can't find my way to the same display with the six tracks on them.

[post:519#5142]
Devil Doll

06/21/2011 06:08 PM

Reviews: 365
Posts: 1574

You seem to have a different ffdshow version. (Scroll down on the left side, select "About"; on the right side a text should appear beginning with "ffdshow tryouts rev3611 Oct 9 2010".)

The blue icon is the audio configuration, the reddish icon is the video configuration of ffdshow.

Selecting the checkbox for "Mixer" doesn't change anything here, but selecting the word "Mixer" makes the mixer configuration dialog appear on the right side (on my PC, that is). It's the same with "Volume" which led you to the six "moving columns".

[post:519#5145]
Stretch

06/22/2011 07:04 PM

Reviews: 1918
Posts: 1313

I see now that I have been confused because the ffdshow icon I have been seeing is the video one--when I place my cursor on it, the words 'ffdshow video decoder' appear. But there is no red here--it is just white letters 'FF' and black letters too small to read (presumably 'dshow') beneath them. Since the taskbar background is blue, that seems to be their background color as well. The only way I can get to 'ffdshow audio decoder' is via 'All Programs'. Clicking on 'About' there takes me to a display entitled 'ffdshow version Nov 17 2006 14:30:20 (msvc 2003, x86, unicode)'. Clicking the word ‘mixer’ (I guess ‘output’ was something else that just didn’t have a checkbox?) takes me to a display of 36 rectangular boxes, with both rows and columns labeled L,C,R,SL,SR, and LFE. This is ‘ffdshow audio decoder configuration’. But none of the boxes has anything in it, so I don’t see any number 1s. I click ‘apply’, but still nothing appears.

Edited on 06/22/2011 07:06 PM.

[post:519#5147]
Devil Doll

06/22/2011 08:43 PM

Reviews: 365
Posts: 1574

My version of the "Mixer" configuration has a dropdown menu "output speaker configuration" with already predefined mixer matrix settings, one of these being "2/0/0 Stereo". It should look like this. If "2/0/0 Stereo" isn't selected already then select it and "Apply"; in any case now set the checkbox for "Mixer".
(In my version there's also a checkbox for "Custom Matrix" that makes this table editable; then I would be able to map each of the 5.1 audio input channels to a 2.0 audio output channel by setting "1" values in appropriate columns for the "R" and "L" row, thus downmixing the audio to a normal stereo signal according to my wishes. The "Volume" dialog would tell you which input channels you get, i. e. which input channels you would have to mix to the two output channels, but hopefully you don't need to define your own matrix if a predefined one already does the trick.)

And on my PC this actually works. I have some MKV container here that contains a 5.1 audio stream (FLAC instead of AC3 but that doesn't matter for the mixing), and selecting "2/0/0 stereo" and activating the mixer by setting its checkbox I get AviSynth & ffdshow to actually downmix that stream to 2.0 stereo. When I then open the AviSynth script in VirtualDubMod and move the mouse over the "blue icon", a tooltip tells me:

ffdshow audio decoder:
input: FLAC, 5.1, 48000 Hz (libavcodec)
output: PCM, stereo, 48000 Hz, 16 but integer

And something close to this would be what you should get, as "PCM stereo" could then be handled by Switch whereas "PCM 5.1" results in the seiyuu voices getting lost. ("↗PCM" is another name for "uncompressed audio".)

If you get that working, you could do the same compression you tried already. Your previous AVI file had 987 Kbps video stream and 6 * 768 = 4608 Kbps audio stream for a total of 5595 Kbps; this time the audio stream should shrink by two thirds, so you get 987 + 2 * 768 = 2523 Kbps, i. e. 45% of 5595 Kbps, thus the resulting AVI file should then have a size of 900 MB. This file should be usable on your DVD player; but before burning a disk for this you better try playing the AVI file with MPC in order to check whether the seiyuu voices are still there, i. e. the downmixing has merged them with the other channels.

And after you got that AVI file playable I'll show you how to extract this audio stream and compress it to MP3 with 128 Kbps so that the final version should have 987 + 128 = 1115 Kbps, i. e. 400 MB for 50 minutes of playing time.

Edited on 06/23/2011 11:59 AM.

[post:519#5148]
Stretch

06/23/2011 03:42 PM

Reviews: 1918
Posts: 1313

Ah, I think I have finally found some of what you want. The closest match I can find is ‘2/0 - stereo’ I applied this, then unchecked and rechecked ‘Mixer’ and applied that as well. At first nothing happened, but when I clicked on ‘Custom Matrix’, numbers appear in the rectangular boxes. In each box which has the same vertical and horizontal label, like row SL meets column SL, the number 1 appears. Everywhere else is a zero. This is too orderly—a diagonal line of ones through a field of zeroes. I doubt if it will tell you much. I don’t know if any AviSynth & ffdshow downmixing to 2.0 stereo is taking place. I assume the idea is for me to run this through VirtualDubMod and see what happens, so I have begun doing that. MAISM.

The thought occured to me to try to change some of the numbers in these boxes on 'ffdshow audio configuration'. If I backspace over the number 1 in box L/L, the box turns red; If I Apply or OK the change, I find that when I reopen the page the number 4 has replaced 1 there--I have no idea why.

The good news is that the completed episode now has a size of 401 MB, which is not terribly large. The bad news is that it seems to have gone mute. For some reason the last attempt now shows a size of 1.93 GB and a BitRate of 4608 kbps (the new one has a BitRate of 128 kbps).

Edited on 06/23/2011 05:23 PM.

[post:519#5150]
Devil Doll

06/23/2011 10:19 PM

Reviews: 365
Posts: 1574

The "diagonal line" of "1" values is not what you want - because it means that every input channel would simply be mapped to the corresponding output channel, i. e. mixing 5.1 to 5.1 and no downmixing at all.
What you want is a matrix that has "1" values only in the rows for "L" and "R" (because these are the two channels of 2.0 stereo) but in the 6 columns of your 5.1 AC3 stream - that's what ↗downmixing means: Create only 2 output channels from the content of 6 input channels. (This will result in a slight loss of quality but if your TV set has only stereo speakers it won't make any difference: Even if your DVD player were able to play 5.1 audio your TV set would still have to do the downmixing. Only if you had a TV set with 5.1 audio speakers you'd be interested in playing 5.1 audio there, and then wonder about getting a better DVD player.)

For your purpose the mixer matrix should look similar to this one (green & yellow color added manually by me):
I say "similar" because the exact set of columns depends on the channels that are used in your AC3 streams, the ones you see as "moving columns" in the "Volume" view of ffdshow. In my example the 5.1 audio input has the channels Left, Center, Right, BackLeft, BackRight and ↗LFE; the 2.0 output audio gets a Left channel taking the signals from Left, Center, BackLeft and LFE whereas the Right channel takes the signals from Right, Center, BackRight and LFE. Or to make it more obvious:

  • The Left and BackLeft channels from the 5.1 input go to the Left channel of the 2.0 output,
  • the Right and BackRight channels from the 5.1 input go to the Right channel of the 2.0 output,
  • the Center and LFE channels from the 5.1 input go to both channels of the 2.0 output.
This is as much as you can probably do when downmixing 5.1 audio to 2.0 audio, thus it is the default setting of the "2.0 stereo" matrix in ffdshow. If, for example, your AC3 audio were using the SideLeft and SideRight channels (I'm not sure if this is even possible, they might be reserved for ↗7.1 audio) you might have to change the matrix accordingly (but probably the matrix has the necessary values already, they're just not shown here because only these 6 input channels do contain data...? I don't have any 7.1 audio material at hand to test this).

If you did "Apply" any unwanted changes to the matrix, you might try the "Reset" button at the top of this dialog which should reset all matrix settings to the default values which should be usable for your purpose already. It is okay that selecting "2/0 stereo" has no obvious effect at first (other than changing the tooltip info for the "blue icon" as I posted already, do you see this as well? Your ancient ffdshow version from 2006 may not have this tooltip though).

Downmixing doesn't change the format of the audio stream (which is "uncompressed" at this stage), only the number of channels. So if 5.1 = 6 channels took a BitRate of 6 * 768 = 4608 kbps then stereo = 2 channels must take a BitRate of 2 * 768 = 1536 kbps. I have no explanation for an 128 kbps audio stream at this stage (you didn't do any compression to MP3 yet!), only that this might be the default BitRate for an empty stream and your "Mixer" configuration currently suppresses all channels instead of mapping 5.1 to 2.0, thus causing the AVI result to be mute.

Edited on 06/24/2011 08:37 PM.

[post:519#5155]
Stretch

06/25/2011 01:46 PM

Reviews: 1918
Posts: 1313

So, are you saying that what I need is a matrix like this?

L C R SL SR LFE
1-1-1-1--1--1--L
0-0-0-0--0--0--C
1-1-1-1--1--1--R
0-0-0-0--0--0--SL
0-0-0-0--0--0--SR
0-0-0-0--0--0--LFE

[post:519#5157]
Devil Doll

06/25/2011 02:13 PM

Reviews: 365
Posts: 1574

Close, but no cigar. Your choice of rows is correct but your columns contain too many "1" values. The "0" values that I colored yellow are there for a reason.
Also, you mapped the the "SL" and "SR" channels of your 5.1 audio stream whereas my example contained the "BackL" and "BackR" channels instead; I can't see your "Volume" data so I can't confirm which channels your "5.1" input actually has. And this could make the difference about whether the seiyuu voices get mapped correctly or get lost in the process.

Your matrix would map the Right channel of your "5.1" input to both the Left and Right channel of your "2.0" output, thus creating a result that sounds like "Mono" signals from 40 years ago, with both the Left and Right channel containing identical signals and thus losing the "Stereo" effect that should be your minimum result. Which means: Your encoding result would be playable but sound unnecessarily dull.

So assuming your choice of columns were correct, you should replace four "1" values by "0" values:

  • columns "R" and "SR" in row "L" (to prevent the "Right" signals to appear in the "Left" channel)
  • columns "L" and "SL" in row "R" (to prevent the "Left" signals to appear in the "Right" channel)
resulting in

L C R SL SR LFE
1-1-0-1--0--1--L
0-0-0-0--0--0--C
0-1-1-0--1--1--R
0-0-0-0--0--0--SL
0-0-0-0--0--0--SR
0-0-0-0--0--0--LFE

Does your ffdshow configuration lack the "Reset" button on the top? Using this would be much easier than defining your own matrix.

Which kind of speakers does your TV set have: "Stereo" or "5.1"/"Surround"? I assumed "Stereo" so far (which means that "MP3 with 2.0 channels" would be your format of choice) but if your hardware would happen to support 5.1 audio and modern fansubs begin to actually support 5.1 audio we might begin to question the whole conversion procedure and consider using different stream formats. Then again, the conversion result can only be as good as the weakest link in the chain which may well be your DVD player (at my place it is the DVD player, being not capable of playing anything beyond 720px width and thus a candidate for replacement in the near future).

Edited on 06/25/2011 02:33 PM.

[post:519#5159]
Stretch

06/25/2011 03:06 PM

Reviews: 1918
Posts: 1313

Like this, then?

L C R SL SR LFE
1-1-0-1--0--1--L
0-0-0-0--0--0--C
0-1-1-0--1--1--R
0-0-0-0--0--0--SL
0-0-0-0--0--0--SR
0-0-0-0--0--0--LFE

There is a 'reset' button, but clicking it only takes the matrix from normal, available-for-modification mode into downlighted, no longer changeable mode. It also seems to change Output Speakers Configuration' from 2/0-stereo to 'Dolby Surround/proLogic', whatever that means. Maybe it means something that alongside the Reset button it says that the decoder is in 'default' mode, which seems to be the only option on the drop-down menu.

I couldn't find the manual for my TV set, but I did find those for the two DVD players that are attached to it. The Philips DVP642 has an Audio Format of digital mpeg/AC-3/PCM and MP3 (ISO 9660). The Insignia NS-DRVCR DVD Recorder/VCR doesn't seem to go into much detail on the 'Specifications' page. Until recently the Philips was my player of choice, then all of a sudden many fansubs lost all audio and became mute when played on it. I think that on one DVD I had something like 15 fansub episodes and only four or so still had audio on the Philips player. Whatever the problem is, the same DVDs still had audio when played on the Insignia player, so I have tended to use it instead lately. I don't know if this has anything to do with the AC3 problem, and didn't want to introduce yet another problem when you had gone to so much trouble to solve the first one. But maybe they are interconnected.

[post:519#5160]
Devil Doll

06/25/2011 03:23 PM

Reviews: 365
Posts: 1574

Your matrix now looks identical to mine; if that's the set of channels that you see moving in the "Volume" display, then go ahead and try the next encoding.

In order to play 5.1 audio, your TV set would require six speakers (five "satellites" and one "subwoofer") to begin with. So this isn't a question of reading your manual, it's about your hardware (↗Home cinema system vs simple TV set with stereo speakers) first and foremost.

The "no longer changeable mode" is fine. Just

  • select "Stereo 2/0" and "Apply", then
  • play some 5.1 audio stream through ffdshow (opening V_Alone_with_audio.avs with VirtualDubMod would do just this), and
  • move your mouse over the "blue icon".
Does a tooltip appear, and if yes, what does it say about the output format?

As for the nature of problem - you are experiencing two different problems:
  • Playing AC3 resulted in garbage, with the culprit having been identified as an old AC3filter codec, now replaced by ffdshow/liba52, so this part has been taken care of already. (While searching for sources for our discussion I ran into a page that mentioned old AC3filter versions being buggy, so perhaps updating your K-lite installation would have taken care of this part already; you may still consider doing this in order to get a more recent MPC, a more recent ffdshow, a more recent set of codecs in general, including a more recent AC3filter than comes with its own downmixing configuration.)
  • Converting 5.1 AC3 audio material to 2.0 MP3 audio material with Switch resulted in a loss of channels with seiyuu voices. Apparently this is your first contact with 5.1 audio material (and mine as well, rest assured), so taking care of the downmixing procedure is something that was never necessary before but has become relevant now, with 5.1 audio streams becoming available in anime fansubs.
As for the "muted" audio streams: You can play these anime episodes on your PC, then open the ffdshow audio configuration, select "Volume", and check which channels are present in these audio streams. (MediaInfo would only tell you the number of channels, not the exact list of channels.) But wait... if these "muted" streams are the result of using Switch for creating MP3 then they're all MP3 2.0 CBR, so how would there be any difference? Did you perhaps use MP3 streams from MKV containers which then might be different in format, such as ↗Variable bitrate or whatever? MediaInfo would tell you (Bit rate mode: Constant vs. Variable).

And you said your Philips player actually supports AC3? I never thought of this possibility. If that's true then you might be able to use the extracted AC3 stream from the MKV container without any conversion - just import it into your VirtualDubMod encoding procedure as if it were an MP3 stream. Apparently AVI may contain AC3 streams: Just now I created an AVI container containing a 5.1 AC3 audio stream with VirtualDubMod on my PC and MPC can play the result without any problem; you may try doing so, burn the result on a DVD, and feed it to your Philips player.

If your Insignia player is this one then it supports MP3 and ↗WMA but no AC3, and certainly not 5.1 audio.

Edited on 06/25/2011 04:23 PM.

[post:519#5165]
Stretch

06/26/2011 08:35 PM

Reviews: 1918
Posts: 1313

My entertainment station downstairs consists of just a large TV set and DVD players, without any auxiliary speakers. When I select 2/0 – Stereo, set the new custom matrix, and Apply, then play V_Alone_with_audio.avs using VirtualDubMod, the audio is sporadic—not quite acceptable again. The only thing that happens when I place my cursor on the ffdshow blue icon is that ‘ffdshow audio decoder’ appears. Somehow I can’t figure out how to get back to the ‘volume’ display from the matrix one.

I don’t see a listing for ‘Bit Rate Mode’ in MediaInfo, nor the words ‘Constant’ or ‘Variable’. I checked several different fansubs.

I did some checking: there are 13 fansubs on a DVD which I burned, and only four have audio when played on the Philips player. Three of those four were downloaded in AVI format and therefore never needed to be run through Switch or VirtualDubMod (I just used the old AllToAVI technique). Every fansub which didn’t need to be converted from MKV to AVI played normally on the Philips player. The fourth is Oretachi 05 from either {Shikakku} or {Shikkaku-Kanjouteki}. The reason why I’m not certain is that I think that MKVExtractGUI2 delivered the audio from the {Shikkaku} version as an H264 file, which I couldn’t figure out how to run through Switch, so I downloaded the {Shikkaku-Kanjouteki} mp4 version. I generally avoid mp4 because I’d gotten the idea that they are more tricky and complicated than MKV, but in this case the opposite seems to have happened.

I think that my Insignia player is the same one as you illustrated—the NS-DRVCR version. The only difference seems to be that my manual has French and Spanish instructions as well as English.

Are you saying that maybe I could bypass Switch and simply use the extracted audio streams in VirtualDubMod?

[post:519#5167]
Devil Doll

06/27/2011 09:57 AM

Reviews: 365
Posts: 1574

Now that you apparently downmixed the 5.1 audio to 2.0, and get a result that's still not acceptable, I'm beginning to run out of ideas. Part of this is due to many messages on your PC being different from their equivalent on my machine, which I believe to be the result of you running a K-lite installation from around 2006.
You haven't installed anything during this thread yet. Are you willing to update your complete K-lite package now? (I don't know which K-lite variant you're currently using though.) I can't promise you that it will improve anything in particular, other than giving you a set of more recent versions of many multimedia components and making it easier for you to reproduce what I'm posting. (For example, the "Bit Rate Mode" attribute of audio streams in MediaInfo which confuses me quite a bit; my MediaInfo version is from 2009 but I believe to remember that you installed MediaInfo during one of the previous threads so it can't be that ancient either.)

One more thing you would get is a more recent (and probably bug-free) AC3filter codec, and if this one worked correctly (after you re-enabled it in the K-lite configuration) you might be able to return to the original way of operation (i. e. using Switch to convert the audio stream to MP3 instead of using the AviSynth script for audio decoding and not yet knowing how to create reasonably small AVI files).

You get into the "Volume" dialog by selecting the word "Volume" on the left side in the ffdshow audio configuration.

As for the fansubs you play successfully on your Philips device: If you name them (anime and group, the format "AVI" is sufficient already) I could look up their technical data in aniDB and check what they have in common. (Such as perhaps all being Variable Bit Rate MP3 streams or whatever; your Switch configuration probably creates Constant Bit Rate which I assumed to play on more devices than Variable Bit Rate, most notably on my Philips DVP3040, but if your Philips device turns out to like Variable Bit Rate better then you could change the MP3 parameters in Switch accordingly.)

For the AC3 stream, yes, there might be the option to use the audio from the MKV container without conversion on the Philips device only (but probably not on the Insignia device), under the following prerequisites:

  • Your Philips player must allow AC3 as content of an AVI container (you only quoted the manual to "allow AC3"), and
  • Your Philips player must allow AC3 with 5.1 channels (and do a proper downmixing to 2.0 all by itself in order to send usable signals to your stereo speakers),
both of which would be another test case for you. You know how to import an MP3 audio stream during the encoding procedure with VirtualDubMod, and you can do exactly the same with an AC3 audio stream. It would be a solution only for AC3 though, not for other audio formats that your Philips player doesn't claim to support.

Motivated by our discussion, and using a Philips DVD player myself, I just tried the above and played an AVI container with AC3 5.1 audio stream there. And to my positive surprise, it works - my Philips DVP3040 plays the file correctly, with both background music and seiyuu voices. With six channels instead of just two the file gets a bit larger than the MP3 variant, and my TV set can't benefit from the additional audio features, therefore I won't make this my permanent format of choice for the time being; still, it's a new information for me that my DVD player can downmix 5.1 audio to 2.0 audio as the manual doesn't even mention 5.1 audio at all.

Edited on 06/27/2011 11:18 AM.

[post:519#5177]
Stretch

06/27/2011 05:42 PM

Reviews: 1918
Posts: 1313

OK, I will update my K-Lite package. Do you think that the Basic version would be good enough?

Here’s everything my MediaInfo had to say about the audio of V_Alone_with_audio.avi:

Audio #0
Codec : PCM
Codec/Family : PCM
Codec/Info : Microsoft PCM
PlayTime : 49mn 28s
Bit rate : 4608 Kbps
Channel(s) : 6 channels
Sampling rate : 48 KHz
Resolution : 16 bits
Video0 delay : 5s 523ms



Ah, I get it—the word ‘Volume’, not the box.

The three AVI fansubs which played without problems on my Philips player were:
{EveTaku} A-Channel - 05 (848x480 XviD MP3){2FBB4A10}.avi
{Hatsuyuki-Hadena}ShouwaMonogatari_-04{704x400}{9DF78A3E}.avi
and
{Ayako-Nishishi}Softenni-05{400p}{7621678E}.avi


I generally take an attitude of ‘if it ain’t broke, don’t fix it’ when it comes to computer stuff. But it seems that technology is moving steadily forward and even if certain programs aren’t broke they are liable to be abandoned as ‘obsolete’.

[post:519#5181]
Devil Doll

06/27/2011 07:30 PM

Reviews: 365
Posts: 1574

K-lite: That's exactly the point - I don't know which "variant" you already have installed, and I don't know whether you can find this out on your PC. I'd suggest installing the same "variant" your already have to give you a minimal change on your PC, neither lacking components that you rely on nor drowning you in additional components. Does your K-lite installation perhaps have its own "update" feature?
(The comments for the variants sound as if "Standard" would be the most suitable variant for you but if your current variant were more than this you might lose some features without being aware of the reason for this. When I go by this table of feature comparison for the variants then "Full" would be required for decoding AC3, i. e. coming with AC3filter, and also the XviD codec for encoding videos.)

MediaInfo: V_Alone_with_audio.avi contains an uncompressed audio stream of PCM format, which implies both "Constant Bit Rate" and "768 Kbps for each channel". If you do the same for MP3 streams (e.g. the three files you mentioned as playing correctly on your Philips player) you should see these parameters, and MP3 streams are what I assumed your encodings to have when you try playing them on your DVD player.

The "non-mute" files you named:

  • Shouwa Monogatari has audio: MP3 VBR 109 Kbps
  • A channel has audio: MP3 CBR 128 Kbps (but how does that play on your DVD player with 848px width?)
  • Softenni has audio: MP3 VBR 175 Kbps
So my theory might be correct: Your Philips player accepts variable bit rate but not constant bit rate (whereas on my Phillips player it's the exact opposite, sigh...).
If you want to fix this then try re-encoding one of these "mute" episodes, but in Switch, load the audio stream, and before starting the "Convert", click on "Encoder Options" for your "Output Format: .mp3", and enable "Variable Bitrate (VBR)" instead of "Constant Bitrate (CBR)". (The other settings should be okay with default values, they're fine-tuning the trade-off between quality and file size.)

And if this works for your Philips player, try playing the file on your Insignia player as well, in order to find out whether you can create MP3 streams that run on both of your players, without having to set the Switch settings back and forth depending on the device you want to use for playing this particular encoding.

Edited on 06/27/2011 07:59 PM.

[post:519#5184]
Stretch

06/29/2011 02:28 PM

Reviews: 1918
Posts: 1313

I can't find any update feature in my K-Lite pack, so I was going to attempt to download the 'Basic' version on top of the old one (FAQ said that this would probably work and I need not uninstal the old one). But whenever I click on 'Download the Basic version' I seem to be transferred to an ad for something else--like 'Windows Internet Explorer 8' or 'Insta Codecs'. There is no longer any mention of K-Lite Basic, and I wonder if I would really be getting what I asked for, or something completely different.

I ran a convenient little two-minute episode of Fireball Charming through VirtualDubMod with the MP3 Encoder set for Variable rather than Constant bitrate. It plays fine on the computer, but the real test will be what happens downstairs. I've got a DVD worth of fansubs almost ready to burn, so I will include it with them.

[post:519#5185]
Devil Doll

06/29/2011 03:27 PM

Reviews: 365
Posts: 1574

As I posted before, you're not merely using K-lite for watching anime but for encoding (to AVI, XviD, MP3), therefore I'd recommend the "Full" version to make sure you get everything you're already using (AC3filter is only part of the "Full" variant so you apparently have been using this one so far).
Following the download dialogs, it led me to this file URL: http://fileforum.betanews.com/sendfile/1094057842/3/1309375459.47e73fef1c7c6db04950ac3281f7a6094a50c26f/K-Lite_Codec_Pack_720_Full.exe

Did you double-check about that "A Channel" file with 848px width?

Edited on 06/29/2011 03:30 PM.

[post:519#5187]
Stretch

06/29/2011 07:17 PM

Reviews: 1918
Posts: 1313

I attempted to download the Full K-Lite version and was told that I had to uninstal my old K-Lite pack before I could instal the new one. I closed down my Windows Internet Explorer according to the instructions. But when I attempt to instal the new pack, I get the message 'File "C:Program FilesK-Lite Codec Packunins000.dat" does not exist. Cannot Uninstal'. I restarted the computer as a whole, and still I get the same message.

I'm sure I resized A-Channel to a width of 704px (it played without trouble on the DVD player); I just didn't bother to change the original label.

Edited on 06/29/2011 07:28 PM.

[post:519#5189]
Devil Doll

06/29/2011 08:12 PM

Reviews: 365
Posts: 1574

When you resized the A-Channel episode, did you add the MP3 stream unchanged? (If so, then I'd be mystified as for which MP3 streams your Philips device plays and which it doesn't.)

That "uninst000.dat" file is most likely the list of actions that have to be performed in order to uninstall K-lite (such as deleting files, deleting registry keys, deleting program manager entries, deleting mappings between programs and file name extensions etc.). If this file isn't there on your PC then the "uninstall" program (which most likely is a generic interpreter of such description files) can't know what to do.
This is only my guessing (as I don't have K-lite) but the root of this issue might be that you installed K-lite to some unusual location, and if the new installer isn't flexible enough to find out where your K-lite installation is located but merely assumes the standard location it may not be able to find this file. Another possibility might be that your K-lite is so ancient that your version didn't have an "uninstall" feature back then, in which case you'd be screwed if the new version demands you to uninstall first... Of course restarting your PC can't help in any of these cases.

  • Does your K-lite installation reside in the directory path where the installer assumes it?
  • Does your K-lite installation have its own "uninstall" program (unins000.exe) that you could execute manually?
  • Do you have the installer program of your old K-lite version archived anywhere? If your installation got broken (such as accidentally deleting the "uninst000.dat" file) then repeating the old installation might reset that old installation's state so that a clean "uninstall" would be possible from there.

Edited on 06/29/2011 08:22 PM.

[post:519#5191]
Stretch

06/29/2011 09:34 PM

Reviews: 1918
Posts: 1313

The K-Lite Codec Pack is stored at My ComputerLocal Disk (C):Program Files. How do I tell where the installer assumes it to be? At that location there is ‘unins000.exe’ with a size of 798KB created on 12/6/2006 at 1:37 PM and modified on 12/6/2006 at 1:2… (modified before it was created?). If I attempt to open it I get the message that the unins000.dat can’t be uninstalled since it doesn’t exist.

The uninstall program (that doesn’t work) is located at All ProgramsK-Lite Codec PackUninstallUninstall K-Lite Codec Pack.

I went looking for archived versions of K-Lite. In my Iomega auxiliary hard drive I found ‘klcodec280f.exe’. The thought occurred to me that maybe ‘kl’ stands for K-Lite. When I attempt to open it I get the message: ‘Setup has detected that you have the following codec package installed on your computer: “Haali Media Splitter” It is recommended that you uninstall that package. K-Lite Codec Pack (Full) offers similar functionality. Uninstalling other packages will keep your system clean and potential problems will be avoided. Would you like to uninstall it? (Yes/No/Cancel)’

By the way, I transferred the old K-Lite Codec package to Iomega just in case anything went wrong, but switched Iomega off before attempting to download the new one. As I grew confused and frustrated, it’s possible that Iomega may have been running while a second attempt was made to download K-Lite Full. But that wouldn’t explain why the first attempt failed, would it?

This was the week 5 episode of A-Channel after all, so I did all the converting at least a month ago, although I didn’t actually burn it until around two weeks ago.

Sorry again for wasting so much of your time…

Edited on 06/29/2011 09:36 PM.

[post:519#5193]
Devil Doll

06/30/2011 01:31 AM

Reviews: 365
Posts: 1574

Philips DVD player: I still don't know which MP3 audio stream is in your "resized" A-Channel episode 5. MediaInfo data, please? ("Constant Bit Rate" resp. "Variable Bit Rate" would be sufficient.)

Several downloads, even simultaneous ones, should be handled correctly by your web browser, by giving them different (auto-generated) file names (Firefox does that by adding some digit to the second copy's file name). They shouldn't interfere with each other.

K-lite: According to your posting, your K-lite installation is located where the new K-lite package expected it to be. Inspecting your K-lite directory, and manually executing the old K-lite package's uninstall program, confirmed that the "unins000.dat" file is missing, meaning that your old K-lite installation appears to be incomplete. (I don't know whether it will be possible to find out why this is so; apparently said file just got lost anyhow. Or perhaps the installation process was aborted back then, and the uninstall script couldn't be created because of this, as obviously the creation of this script containing all the path names of your installed files must be the last step of the installation process?)
2006-06-12 (or do you mean 2006-12-06?) appears to be the date when your K-lite package was installed on your PC. But "K-lite 2.80f" ("f" meaning "Full" here) was released 2006-12-17, so apparently you're running an even older version. Does your K-lite installation display its own version number anywhere in its configuration dialogs?

Haali: This is your splitter for MKV containers into streams; you see its icon when you play MKV containers with MPC so this is a core module of your media installation. Nowadays Haali is part of K-lite (as well as a part of CCCP); the What's New section for K-lite 2.80 says that this very version is the first one where Haali was added. So if you're running an even older K-lite version, apparently you have installed Haali as a separate product, which the K-lite installer now detected and complains about.
Haali is a relatively simple module with very little configuration; you're most likely running it with default values, so when uninstalling it you won't lose a lot of work there. With this in mind, uninstalling Haali and then installing a K-lite pack that contains a probably more recent Haali version doesn't sound so bad an idea; the fewer packages from different sources you have installed, the less likely they'll clash with each other (and from what I see here, at least the older K-lite versions appear to be a bit picky about their prerequisites).
We'll probably not end up installing CCCP on your PC but I'd certainly prefer one clean and recent K-lite to whatever ancient software you might be running right now. The idea is to install K-lite 2.80 for the only purpose of being able to do a clean uninstall for this package while installing K-lite 7.20 later; if uninstalling Haali is the prerequisite for this then it looks like you have no choice but try this (and hope that the K-lite 2.80 installation can be completed successfully, thus creating an "unins000.dat" file...).

I watched a few K-lite installation guide videos on YouTube (but found none that I could really recommend to you, the good ones are either too specific or install K-lite as part of a larger project). The installation dialog consists of these parts:

  • Which modules should be installed? (I'd suggest "everything except for the 'tools' block".)
  • Which modules should be responsible for which features? (Similar to the configuration section where you disabled AC3filter; some of this is a matter of personal preferences.)
  • Which file types should your video player of choice be responsible for? (I'd suggest "everything" as you're most familiar with MPC.)
You won't need this for installing K-lite 2.80 (which you're going to uninstall immediately afterwards, so using the default settings is fine here) but for K-lite 7.20.

Edited on 06/30/2011 01:29 PM.

[post:519#5195]
Stretch

06/30/2011 02:48 PM

Reviews: 1918
Posts: 1313

A-Channel must have had constant bitrate, since I converted it long before I even knew that variable bitrate existed.

I assume that 12/6/2006 means December 6th, 2006.

I could tell you exactly what version of ffdshow, or Media Player Classic, or any other sub-program of K-Lite I have, but nowhere can I find any statement of what version of K-Lite itself this is. The ‘readme’ file, for example, starts off with ‘Pre-installation instructions’ without any heading that might state exactly what version of K-Lite this is.

So, are you saying that I should transfer klcodec280f.exe from Iomega back to the main computer, and install it there, which will hopefully replace the version of K-Lite which refuses to uninstall? And if that works, replace 280f with version 7.20? I ‘sent’ 280f to the main computer, and attempted to ‘Open’ it there, which prompted the same message which recommended that I uninstall Haali Media Splitter.

...and the variable bitrate episode of Fireball Charming still didn't have any audio on the Philips player. (:c)

Edited on 06/30/2011 04:00 PM.

[post:519#5197]
Devil Doll

06/30/2011 06:43 PM

Reviews: 365
Posts: 1574

I give up on trying to understand your Philips player. ;-(

For K-lite: Yes, that was the idea. If you need a correctly installed K-lite in order to install K-lite 7.20, and you need to uninstall Haali in order to get a correctly installed K-lite 2.80, then it looks like you have uninstall Haali first in order to get anywhere at all. If anything doesn't go well, http://haali.su/mkv/ would be the place where to get a separate Haali installation program and re-install it but hopefully you'll end up with K-lite 7.20 and Haali being a part of this package.

Edited on 06/30/2011 06:45 PM.

[post:519#5206]
Stretch

07/03/2011 04:08 PM

Reviews: 1918
Posts: 1313

Sorry this has taken me so long. I moved K-Lite 280f from Iomega to the main computer. I uninstalled Haali—I think—except at All Programs/K-Lite Codec Pack/Configuration there is still a display entitled ‘Haali Media Splitter Properties’. There doesn’t seem to be much to it. though—just the title, designer’s name, copyright date, and ‘options’ that include ‘compatibility’, ‘input’, ‘output’, ‘languages’, ‘interface’, ‘HTTP reader’, and ‘explorer integration’. Hopefully this is just some leftover. At least I didn’t get any more messages saying that I still needed to uninstall Haali. I clicked on your link to K-Lite 7.20 and began installing it. I was told to close Windows Explorer (Mikomi), which I did. I got the message that my old K-Lite pack was incompatible with the new one and asking me if I wanted to uninstall it, and I clicked on ‘yes’. This time I got a new message which recommended that I uninstall ‘DirectVobSub’; the message said that 7.20 would be able to do the same things, so I approved the uninstalation. I also needed to verify that I wanted to uninstall, which I did, then closed the DirectVobSub uninstall program once it said the task had been completed. This took me pack to the K-Lite Codec Pack 7.20 (Full) installation program. I approved ‘Advanced Install (show all options)’ since that was the choice of default. I also approved the default choices of where 7.20 should be installed, which components should be installed, where shortcuts should be placed, and the options for configuring the chosen components. There was a message about ‘Internal DXVA Decoders’, but those seem to be found only in computers built in 2008 or later, so I doubt if it applies to mine. If they are missing decoding seems to automatically take place elsewhere, and they sound like they might be troublesome anyway. I clicked ‘Next’. I approved ‘File Associations’ (whatever those are) with MPC rather than WMP. The next display confused me. The default choice for ‘File Extensions’ seems to be every possible kind of video, but only one kind of audio: ‘Playlist File Extensions/mpcpl’. Rather than fool with something I know nothing about, I clicked on ‘Next’ yet again. Next, I approved the default choice for File Extensions regarding Thumbnail Generation. Next, under ‘Speaker Configuration’ I approved 2.0 (stereo). Here there was an option for 5.1 Surround, but I presume that would be meaningless since my TV set doesn’t have a fancy set of extra speakers. Finally, I was told that Installation was ready to begin and I told the computer to begin. I needed to close the original K-Lite 7.20 website to proceed. Before long I was told that the process was done. There was an option to configure ffdshow audio and video decoders, plus DirectVobSub, but I left those alone and clicked ‘Finish’. I was immediately taken to an ad for K-Lite Codec Pack 7.2.5! I felt that I had done enough updating already and would wait to see what your thoughts were. What do you recommend I do next, to test the new codec pack?

[post:519#5208]
Devil Doll

07/03/2011 08:01 PM

Reviews: 365
Posts: 1574

"Windows Explorer" is the program where you navigate through the folders of your PC, not "Internet Explorer" where you navigate through the WWW (such as "Mikomi"), so I'm surprised that you needed to close the latter. But in Windows, both programs are closely interrelated so who knows. (The reason why you had to close the Windows Explorer is probably because Windows Explorer is responsible for handling file associations and the installation process was about to change these and a restart was necessary in order to make the changes known to Windows Explorer.)

In general, the installation process sounds successful. Uninstalling ↗DirectVobSub (your subtitle interpreter) was similar to uninstalling Haali, getting rid of another individually installed product that is now part of K-lite. Hopefully your choice of "Speaker Configuration" will be used for the "Mixer" setting(s) in K-lite.

K-Lite Codec Pack 7.2.5 is a minor update for K-lite, small enough that the authors don't even offer it as a full installation package but merely as an update for an already existing 7.2.0 installation (in order to prevent unnecessary download volume). It's okay to get and install it if you want. The explanation text says: "It contains updates for Media Player Classic, ffdshow, Xvid, DirectVobSub, Win7DSFilterTweaker, and the Codec Tweak Tool" so most of this refers to modules you're actually using. I'd expect the installation dialog to be much simpler than the full 7.2.0 pack, the update might even just overwrite or ↗patch some program files and not ask for any configuration.

"↗File association" is a mapping between a group of files with the same file name extension and a program being responsible for handling files of this type. For example, the fact that you can double-click *.mkv files in order to get them played by the MPC video player is due to the fact that someone has established an association between all *.mkv files and the MPC program before, typically during the installation of said program.
K-lite is a pack for playing videos, so it doesn't ship with an audio player such as WinAmp, and stealing away the file associations such as *.mp3 from your possibly already installed audio player (Windows Media Player could play a few audio types but with a lot less features than a fully-fledged audio player) would not be reasonable, with the one exception of "mpcpl".

As a general test for the new K-lite installation you might try playing as many different anime videos as possible, most notably MKV containers with high quality attributes as they're likely to use different codecs, and as many different container types as possible. If anything isn't working any more, check the file content with MediaInfo and look up the K-lite configuration for the corresponding codec type.
You might also take a quick glance into ffdshow audio configuration (the "blue icon") and see how it looks like and what has changed in comparison to your old version.

As for the current discussion thread here, I recommend enabling AC3filter for interpreting AC3 audio in the K-lite configuration (because that's what we disabled due to the old AC3filter having been buggy) and then repeating all the tests in this thread, beginning with:

  • Play the extracted AC3 file with Switch
  • Convert the extracted AC3 file to MP3 with Switch, then check whether the seiyuu voices are still there. (If not then we would have to visit AC3filter's own downmixing configuration and check the settings there.)

Edited on 07/03/2011 08:57 PM.

[post:519#5214]
Stretch

07/04/2011 11:53 AM

Reviews: 1918
Posts: 1313

If I remember correctly, AC3 filter is enabled and disabled within Codec Tweak Tool. I found that this had been redesigned and had become more complicated. Looking for the word ‘Filter’ at the ‘Codec Tweak Tool 4.9.5’ table of contents I found ‘DirectShow Filter Configuration’, ‘Manage DirectShow Filters’, and ‘Manage Source Filters’. The only one of these three options where I found a mention of AC3 was under ‘Manage 32-bit DirectShow Filters’. There, under ‘Enable the following inactive filters’ (the place where I expected to find what I was looking for) there was no mention of AC3. The only reference to AC3 came under ‘Disable the following inactive filters’ where there was ‘AC3 File {ac3file.ax}’. Does that mean that the filter has already been re-enabled by default? Or am I looking in the wrong place? As of yet I have done nothing for fear of screwing up.

[post:519#5221]
Devil Doll

07/04/2011 05:22 PM

Reviews: 365
Posts: 1574

I have no idea how K-lite configuration dialogs look like. But from your description it seems that K-lite enables AC3filter as installation default.

Let's sum up what happened so far:

  1. Converting an AC3 audio stream turned out to be difficult as Switch didn't set a file association for this type.
  2. Manually loading the AC3 stream into Switch ended up producing a garbage result.
  3. Playing the AC3 stream with Switch produced different messages on your PC than on mine, thus we detected that on your PC AC3filter was used by K-lite for decoding AC3 audio streams.
  4. We disabled AC3filter and made ffdshow/liba52 decode AC3 streams but the quality remained low.
  5. Now playing the AC3 stream with Switch suddenly produced good quality but the encoding to MP3 selected only 2 channels from the 5.1 AC3 audio stream instead of properly downmixing all channels, causing the seiyuu voices to be lost.
  6. We tried to bypass Switch by decoding the AC3 audio stream via an AviSynth script and thus using the ffdshow configuration but the result was still not satisfactory.
  7. We tried to fix the downmixing issue of Switch by configuring the downmixing in ffdshow's "Mixer" section, but somehow didn't get any result whose quality you actually posted.
  8. Experiencing too many differences between your old software and the 2011 state of art, we decided to upgrade your K-lite package, getting an updated AC3filter codec in the process which is now again configured for decoding AC3 audio streams.
So now we're back to square 1 of this thread - well, actually we're at step 2 or 5 of the previous list once again, depending on how we look at things.
  • What happens when you play the extracted AC3 track with Switch? How is the quality?
  • What happens when you convert the AC3 track to MP3 with Switch? How is the quality? Are the seiyuu voices still there?

Edited on 07/04/2011 07:08 PM.

[post:519#5227]
Stretch

07/04/2011 08:35 PM

Reviews: 1918
Posts: 1313

I attempted to play the Votoms Alone Again AC3 audio track using Switch. The warning ‘Format may not be supported’ is still present. As before, Switch paused for awhile, but once it finally began playing the audio seems perfectly acceptable. Next, I instructed Switch to convert the file to mp3 and overwrite the already existent mp3 track. I notice that the AC3 track has a different icon now, Windows-like one. When finished, I played it with MPC. All seems well! Voices, BGM, sound effects are all present. The ultimate test will be to run it through VirtualDubMod and see how it plays on the DVD player. If only I hadn’t done everything possible to avoid a major change in my computer’s programming…

[post:519#5229]
Devil Doll

07/05/2011 12:50 AM

Reviews: 365
Posts: 1574

If you have set Switch back to "constant bit rate" for the MP3 encoding then from this point on nothing can go wrong any more; the MP3 stream isn't changed by VirtualDubMod, only inserted into the AVI container (whereas the video stream is changed in VirtualDubMod because someone has to resize the screen resolution and add the subtitles).
Having said that, there's still the mystery about which audio streams your Philips player is able to understand, and if you're interested we can deal with this once "Votoms" plays on your Insignia player.

Switch still doesn't natively support AC3, and K-lite didn't install a new Switch version, so the warning won't go away. But as long as K-lite (or ffdshow or whoever may be responsible for decoding AC3 on your PC) can properly decode AC3, Switch will be able to encode the result to MP3.

From your results I derive that

  1. AC3filter isn't buggy any more and
  2. AC3filter comes with a proper 5.1 to 2.0 downmix configuration, that's why it delivered an uncompressed 2.0 audio stream to Switch with no voices/channels missing. Just what I was hoping for.
The additional icon for AC3 is probably a side effect of someone making a file association for *.ac3 files, i. e. specifying a program that opens these files. As this isn't Switch (which wasn't part of your K-lite installation) it must be some component of K-lite, one that I'm not aware of. If you double-click that AC3 file now you will see which program this is... perhaps K-lite 7.2.0 comes with its own AC3-to-MP3 converter these days? Then again, it might be as simple as MPC being responsible for playing AC3 streams.

Does your updated MPC now have the menu entry "File" / "Properties" / "MediaInfo"?

Edited on 07/05/2011 01:04 AM.

[post:519#5231]
Stretch

07/05/2011 10:27 AM

Reviews: 1918
Posts: 1313

I realized that Switch was still set for Variable BitRate Encoding, so I switched it back to Constant Rate and repeated the experiment. The sound is the same, correct and normal. Since Switch is set for ‘output to same folder as source files’, and I instructed it to overwrite the already existent audio stream, whatever mp3 audio track exists there will be the result of my last test run, right? The only (slight) problem is that volume is a little low, but I think turning up the volume on the TV set would be perfectly adequate to fix this. In fact, my experience in the past has been that almost all anime are far too loud compared to ordinary TV programs, and I have made a habit of turning the volume down to about half the normal level while watching fansubs. I now get MPC ‘Home Cinema’, whatever that means. It turns out that I do have a File/Properties/MediaInfo capability—it’s sort of a shorter version of the data I get from the old MediaInfo program. Here’s what it had to say about Votoms Alone Again:

General
Complete name : C:Documents and SettingsOwnerMy DocumentsV Alone
A[gg]ArmoredTrooper_VOTOMS_-AloneAgain_(BD,1080p)EA07E1F7track2.mp3
Format : MPEG Audio
File size : 45.3 MiB
Duration : 49mn 28s
Overall bit rate : 128 Kbps

Audio
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Duration : 49mn 28s
Bit rate mode : Constant
Bit rate : 128 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 45.3 MiB (100%)

Apparently, double-clicking on a stream or fansub will now take me to MediaInfo as well. In the past I always opened MediaInfo separately, then went looking in ‘My Documents’ for whatever fansub I was interested in. I will re-convert and burn Alone Again onto a DVD and see what happens.

[post:519#5233]
Devil Doll

07/05/2011 02:39 PM

Reviews: 365
Posts: 1574

Here at my place, my TV satellite signal is louder than the audio signal from my Philips DVD player, and the speakers are louder than my headphones (which I'm using for many anime in order to get the full stereo experience for good music), so I'm used to changing the volume settings on my TV set every time.
But in case you get tired of having audio streams of varying loudness, there are tools for normalizing the volume of MP3 streams. As I mentioned before, I am frequently playing my "Best of Anime Music" collection in WinAmp in random order, with MP3 files from various sources and with varying volume levels; to get all of these to one level of loudness I ran them through a small tool I downloaded from http://mp3gain.sourceforge.net/. When watching anime, I have to adjust the loudness setting just once per series (as I'm usually watching one series in batch mode instead of switching between different stories), so I don't need this tools for my anime encodings.

I have the same "overwrite behavior" setting for Switch as you do, and it works as you expect it to. (When in doubt, you can always check the modification date of the MP3 file and inspect its content with MediaInfo.)

You get MediaInfo data when double-clicking any video? That's probably not what you want. Here on my PC, when I select a file, and via context menu select a program to "open" this file, there's one checkbox named "always open this file type with this program"; using this would change the file association for this file type, i. e. make the program I selected the one to be used for double-clicks on this file type from here on.

Your example for MediaInfo referred to the MP3 file, that's why you believe it's shorter. Try the same on an AVI or MKV container.

Your Windows operating system has a feature named "Send To". When you select a file and activate its context menu (right mouse click), one of the entries should be "Send To", opening a sub-menu with volume drives (thus "sending" means "copy") but also programs (then meaning "open with"). I created a "Send To" entry for MediaInfo a long time ago, so that's my way of invoking MediaInfo for various file types.

Edited on 07/05/2011 02:54 PM.

[post:519#5235]
Stretch

07/05/2011 05:01 PM

Reviews: 1918
Posts: 1313

Well, now when I do a test run of Alone Again on VirtualDubMod (I haven't converted it, I'm just trying to see if voices and video are in sync), I get a terrible start-and-stop quality. Every second or so both the audio and video pause abruptly; just for an instant, but it messes up the 'flow' of the show. I have already converted several new Summer series fansubs since updating K-Lite, and there were no problems with those. It's as if we are back at square one: there's something about Votoms Alone Again which is more complicated than the average fansub and the usual techniques just don't work here.

Actually, I guess what happened regarding MediaInfo was that clicking once with the right button causes a list of options to appear, and one of those is 'MediaInfo', which I guess I hit with the second click.

[post:519#5241]
Devil Doll

07/05/2011 07:59 PM

Reviews: 365
Posts: 1574

And you're sure it's not just the DVD you're using? Rewritables don't live forever, and videos "hanging" might be the result of the DVD player having to retry the read operation for a sector on the disk.

Once you have converted an episode to AVI with XviD and MP3-CBR, there's no reason why playing it with MPC on your PC should produce different results than playing it on your DVD player, other than experiencing media read errors.

Try burning the same file several times on the same DVD so that the copies will use different locations on the disk. Does that help?

[post:519#5242]
Stretch

07/05/2011 09:04 PM

Reviews: 1918
Posts: 1313

What I meant was, I haven't burnt Alone Again onto a DVD yet (not since the K-Lite update, that is) because the results I get when I play it on VirtualDubMod are poor and I assume I would get the same if I did burn it and play it on a DVD player. Should I go ahead anyway? I'm not using rewritable DVDs.

[post:519#5244]
Devil Doll

07/05/2011 09:40 PM

Reviews: 365
Posts: 1574

How can you "play" a video on VirtualDubMod? You're reading the AviSynth script with the aforementioned huge data masses (uncompressed video) so you can never expect VirtualDubMod to behave like a video player in terms of "real time performance". That's exactly the same as when you directly play the AviSynth script with MPC.

Does the resulting AVI file play without delay in MPC resp. WMP? That's what matters. If you want to make a short test then in VirtualDubMod, use the two rightmost widget icons (tooltips: "mark in" / "mark out", the ones I surrounded in red: ) to mark a small time interval of the episode in question, then run the compression (which will then last only a few seconds) and check the result.

As for rewritables, I can recommend them for testing purposes as they do last a while, and as such are a bit cheaper than DVD-ROMs. I always watch new anime from rewritables and only burn permanent DVDs when archiving a series, thus I never burn a DVD-ROM without knowing that my player can read the data.

Edited on 07/05/2011 09:50 PM.

[post:519#5245]
Stretch

07/05/2011 09:57 PM

Reviews: 1918
Posts: 1313

OK, while I was waiting for your reply I started the VirtualDubMod conversion process, and once it is finished I will check the final result with MPC and/or WMP, and if all is well, burn it.

I usually arrange to get a 100-pack of blank DVDs at Christmas time, and they last me for a year. They average around 40 cents each so cost isn't a problem if I'm careful not to waste them. I have some rewritable discs but haven't made much use of them.

Edited on 07/05/2011 10:02 PM.

[post:519#5248]
Stretch

07/07/2011 11:13 AM

Reviews: 1918
Posts: 1313

Good news! Alone Again, on a DVD, plays normally on both the Insignia and Philips players. So does every other fansub I included on the disc, which is the first to be burned since the K-Lite update.

So, did Stereo 5.1 sound or some other audio technology come along suddenly, and almost all fansubbers embraced it almost simultaneously? Because I hadn’t changed my technique of converting on VirtualDubMod when this trouble began, and for a good while the episodes on my DVDs played just fine on Philips.

(Mikomi was 'temporarily unavailable' all day yesterday).

Edited on 07/07/2011 11:26 AM.

[post:519#5250]
Devil Doll

07/08/2011 12:30 AM

Reviews: 365
Posts: 1574

I think TV airings are less likely to have 5.1 sound compared to movies/OVA, and Votoms belongs to the latter. (The 5.1 reference material that I was using for my tests is Suzumiya Haruhi no Shoushitsu.) The idea of 5.1 surround sound is to assume you actually have six speakers in an appropriate arrangement around the consumer which you can guarantee in a cinema hall while not many private households have a home cinema set already. There might be some pay tv programs already using 5.1 sound but I don't know for sure. BluRay releases are even using ↗7.1 sound already, so expect this to occur in the near future (Evangelion Shin Gekijouban: Ha uses ↗6.1 audio, I have yet to find a 7.1 anime release though).

Assuming that now your AC3 issue can be considered closed, we might focus on the Philips device if you want. Take whatever DVD you want, play it on the Philips player, and if any file is mute, post its MediaInfo data here.

Edited on 07/08/2011 01:06 AM.

[post:519#5252]
Stretch

07/08/2011 12:49 PM

Reviews: 1918
Posts: 1313

Actually, the new-technology-suddenly-coming-along theory was more about why fansubs seemed to abruptly lose audio on the Philips player than about Alone Again. The only other explanation I can think of is that one of the 'updates' that Windows occasionally performs on my computer might have somehow altered something--I know that's unlikely.

Here's something strange: on the same DVD I also included a number of fansubs (the 'Spring Week 7' batch) which had definitely been run through Switch and VirtualDubMod before the K-Lite update. They now have audio on Philips as well! Maybe disabling the AC3 Filter was responsible? I didn't write down the date when I converted these shows, so I can't be sure which came first.

Edited on 07/08/2011 12:58 PM.

[post:519#5254]
Devil Doll

07/09/2011 04:11 AM

Reviews: 365
Posts: 1574

You're converting AC3 to MP3 on your PC already, so if the MP3 stream plays on your PC then AC3filter can't be responsible any more.
If the MP3 is mute on the Philips player but usable on the Insignia player then the reason should be an effect of the MP3 encoding parameters (hence my assumption that CBR/VBR makes the difference, there's not much else you can configure in MP3). It's the same with some fansubs in AVI not playing on my Philips DVD player because their video stream uses certain XviD parameters that my player doesn't support correctly (QPel and GMC3).

I agree about Windows updates being an unlikely candidate for meddling with your codecs as only few of these came with Windows (such as the MP3 decoder which is a prerequisite for Windows Media Player), and the ones you're using in this case are most likely all installed with K-lite (such as the MP3 encoder).

Edited on 07/09/2011 05:47 AM.

[post:519#5256]
Stretch

07/10/2011 10:06 AM

Reviews: 1918
Posts: 1313

Well, so far everything seems to be working normally again. I can't explain why fansubs on the Philips player regained audio, but I certainly won't complain about it. Thanks again for all your time and trouble; I had thought that this was a relatively simple problem (and maybe it would have been if I hadn't procrastinated for so long about updating K-Lite). Sorry about that. Hopefully I won't be needing to add anything else to this topic--at least not until my current technology is rendered obsolete and I am left wondering what's going on!

[post:519#5259]
Devil Doll

07/10/2011 03:33 PM

Reviews: 365
Posts: 1574

Well, it helped me to learn a few things about 5.1 audio, about downmixing in Windows, and even about K-lite. Feel free to ask again whenever necessary.

Reply to this topic Start a new topic
Back to topics list

Community Anime Reviews

anime mikomi org